SSH

SmartFTP thực hiện được các đặc tính sau đây của giao thức Secure Shell (SSH).

Tính năng

Tuân thủ các tiêu chuẩn bảo mật

Các phương pháp xác thực

Các phương pháp xác thực sau đây được hỗ trợ:
  • Mật khẩu
    Username/password và chứng thực tương tác bàn phím. Đồng thời hỗ trợ các yêu cầu thay đổi mật khẩu máy chủ.
  • Khóa Công
    Tệp tin khóa (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), chứng thực X.509, chứng thực Microsoft Windows từ kho chứa hay từ Smart Card (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Hỗ trợ thi hành Microsoft Windows Kerberos (SSPI) và MIT Kerberos (GSSAPI).
  • Máy chủ chứng thực
    Xác thực bằng tệp tin khóa hay chứng thực.
  • RSA SecurID
    Xác thực hai yếu tố RSA SecurID.

Mã hóa

Nén

Các Cách thức Trao đổi Khóa

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Thuật toán khóa công cộng

HMACs

Tiện ích mở rộng