SmartFTP won't load

Hi all,

I searched the forum (and I googled the problem) before I ended up writing this post. This means I tried rebooting, reinstalling, cleaning the registry, deleting the SmartFTP key in the registry, ...

What's the problem I got? SmartFTP simply doesn't load anymore, no splash screen, no nothing. The problem occured after I tried to install the latest version and the program told me I had to update my maintenance. Funny thing is the website doesn't let me pay for it. After I select the 3 year option, fill out the form and click next I just get a blank screen. I tried it in 4 different browsers ... no cigar.

I thought the problem with the payment might be a server side problem and so I continued the installation. Result? No more SmartFTP... (Up till now I'm still not able to pay.)

So I have two questions for the SmartFTP team:

1. How can I pay with my Mastercad without getting the blank screen after I filled out the form?
2. How do I get my beloved SmartFTP up and running?

FYI. Win 7 - 64bit

Thank you for any suggestions.

I don't know why I didn't try this before, but I decided to RDP to my pc at home and give the payment another try. Guess what. It worked. Maybe my office ip was temporarily blocked, I don't know.

Well at least we got half the problem solved now. I'll keep you posted on question number two.

I noticed the process is showing up in the process window of the taskmanager for a short while (~ 5 to 10 secs), just to disappear.

It usually means that the file is already on the server and therefore the transfer is skipped.

Try to run it on a different user account.

I tried running it under different user accounts but ... still no cigar.

Would the results of doing this bring us any closer to a solution?

If SmartFTP crashes during startup, yes:
- Install the latest version of SmartFTP to ensure that you really have the latest version
- Then follow in the instructions in the article. Don't forget to enable this:
If SmartFTP crashes during startup. Download the archive and double click the ShowDebugMessage - Enable.reg.

What you can also try is to enable debug logging: ... f2613.html

Stefke, did you solve your problem? I have the exact same problem.

Yesterday everything was fine with 1189 and after the update to 1190 nothing happens execpt the task manager entry that is visible for a couple of seconds.

Can you provide a crash dump?

Still the same with 1191 after the upgrade. Then I tried starting it after deleting the registry entry. And last I deinstalled it and installed it again.

There is a new crash dump.

Your installation is corrupt:
- Uninstall SmartFTP
- Reboot if you are prompted to do so
- Delete the complete D:\Internet\SmartFTP Client folder
- Install SmartFTP from here:

To avoid problems in the future, do not manually copy/move files etc

It's working again.

There was no prompt to reboot, though. Perhaps I forgot it earlier and it stuck somewhere in the system.

Thanks for your help.