Explorer Folder View Runtime Error

nhl2k

2011-02-11 22:58:59

We recently upgraded SmartFTP from version 3 to version 4 and have encountered a reproducible explorer crash while connecting to a site in SmartFTP. I have done this on 2 Windows XP SP3 PCs to try to eliminate the possibility of it being an issue with a specific PC.
We are running the latest version (4.0.1166.0) and if we have an explorer window open that has (or had) the Folders pane open, when we connect to a site using SmartFTP we get a Runtime Error from Microsoft Visual C++ Runtime Library for c:\windows\explorer.exe. The details say that the application requested the runtime to terminate in an unusual way.
I deleted the Client 2.0 registry key to see if fresh settings would help and we still get runtime error.

Thanks

mb

2011-02-11 23:04:00

Try to uninstall SmartFTP. Then reboot. And then install SmartFTP from here: https://www.smartftp.com/download and reboot again.
If the problem persists we need a crash dump:
https://www.smartftp.com/support/kb/how- ... f2594.html

In the advplus command line found the in the article above replace -pn SmartFTP.exe with -pn Explorer.exe

The reason for the crash is most likely a 3rd party shell extension that incorrectly handles the shell notifications from SmartFTP. But the crash dump will tell us more.

Thanks
Mat

nhl2k

2011-02-14 15:38:07

Mat,
I decided to try this on a fresh install of Windows XP SP3 in Oracle VirtualBox. Without installing anything besides Firefox, I still get the RunTime Error.
I followed the directions to get the crash dump for Explorer.exe and I have it here:

http://users.lusfiber.net/~steven.baudo ... rCrash.zip

Thanks again for your assistance.

mb

2011-02-14 19:24:37

Thank you. Adplus is a bit problematic. It creates a crash dump for every user exception even if it is handled. And the crash dump you have uploaded is one of those handled user exceptions. I have sent you a new version per email which shouldn't cause adplus to create a dump. Please give a try.

nhl2k

2011-02-14 20:11:20

Mat,
I'm not sure if you were asking me to do another Adplus trace with this update or if you thought this update would fix the problem, but I'm not getting the runtime error with this new version.
The only strange thing was that when I went to install, it said "A newer version is already installed." and I had to uninstall the old version to install this one instead of just updating.
If this was the fix, thanks it worked. If not, let me know what you'd like me to do.

mb

2011-02-14 21:16:48

Thank you for you tests. We have now found and fixed the bug. The workaround in the build I have sent you ensured that the bug is not triggered.

nhl2k

2011-02-14 21:37:20

Thanks Mat. We appreciate the support. Do you know what's up with the installer thinking this is a previous build and aborting the installation?

mb

2011-02-14 23:25:40

We did not increase the build number but only the patch number. This causes the installer to think that you are trying to install the same version.
Please install the newest version: https://www.smartftp.com/download/

nhl2k

2011-02-15 14:44:37

Thanks Mat. We were able to update to the latest version and it's working great.