Cannot connect to my server

Khaldoun

2010-11-18 21:55:21

I recently got myself a storm server from LiquidWeb.
No matter what I do, I could not connect to the server through Smart FTP.
The connection will always time out.

So, I tried FileZilla and was faced with the same problem.
Downloaded the trial version of WS FTP and it connected immediately.

Apparently, there is some kind of an issue when it comes to connecting to a Storm Server.
Can you please advise.

I'm running Smart FTP 4.0.1145.0
The following is the error message that I keep getting:

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.


Thanks,
Khaldoun

mb

2010-11-18 21:55:53

Please post the complete log.

Khaldoun

2010-11-19 01:29:28

Here you go:

[20:11:20] SmartFTP v4.0.1145.0
[20:11:20] Resolving host name "18cordlessdrill.org"
[20:11:21] Connecting to 69.167.169.51 Port: 21
[20:11:21] Connected to 18cordlessdrill.org.
[20:11:21] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[20:11:21] 220-You are user number 1 of 50 allowed.
[20:11:21] 220-Local time is now 20:11. Server port: 21.
[20:11:21] 220-This is a private system - No anonymous login
[20:11:21] 220-IPv6 connections are also welcome on this server.
[20:11:21] 220 You will be disconnected after 15 minutes of inactivity.
[20:11:21] USER cordless
[20:11:21] 331 User cordless OK. Password required
[20:11:21] PASS (hidden)
[20:11:21] 230-User cordless has group access to: cordless
[20:11:21] 230 OK. Current restricted directory is /
[20:11:21] SYST
[20:11:21] 215 UNIX Type: L8
[20:11:21] Detected Server Type: UNIX
[20:11:21] RTT: 31.269 ms
[20:11:21] FEAT
[20:11:21] 211-Extensions supported:
[20:11:21] EPRT
[20:11:21] IDLE
[20:11:21] MDTM
[20:11:21] SIZE
[20:11:21] REST STREAM
[20:11:21] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[20:11:21] MLSD
[20:11:21] AUTH TLS
[20:11:21] PBSZ
[20:11:21] PROT
[20:11:21] ESTA
[20:11:21] PASV
[20:11:21] EPSV
[20:11:21] SPSV
[20:11:21] ESTP
[20:11:21] 211 End.
[20:11:21] Detected Server Software: PureFTPd
[20:11:21] PWD
[20:11:21] 257 "/" is your current location
[20:11:21] TYPE A
[20:11:21] 200 TYPE is now ASCII
[20:11:21] PASV
[20:11:21] 227 Entering Passive Mode (69,167,169,51,152,10)
[20:11:21] Opening data connection to 69.167.169.51 Port: 38922
[20:11:21] MLSD
[20:11:42] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

mb

2010-11-19 03:02:55

Khaldoun

2010-11-19 13:17:25

I should have mentioned in my first post that I also tried active mode and it did not work.




You can try active mode (PORT):
https://www.smartftp.com/support/kb/how ... de-f1.html

mb

2010-11-19 18:37:38

Post the log from SmartFTP using active mode. And also post the log from WS_FTP.

Khaldoun

2010-11-20 04:41:16

Log from SmartFTP using active mode:

[23:22:52] SmartFTP v4.0.1145.0
[23:22:52] Resolving host name "18cordlessdrill.org"
[23:22:52] Connecting to 69.167.169.51 Port: 21
[23:22:52] Connected to 18cordlessdrill.org.
[23:22:52] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[23:22:52] 220-You are user number 1 of 50 allowed.
[23:22:52] 220-Local time is now 23:22. Server port: 21.
[23:22:52] 220-This is a private system - No anonymous login
[23:22:52] 220-IPv6 connections are also welcome on this server.
[23:22:52] 220 You will be disconnected after 15 minutes of inactivity.
[23:22:52] USER cordless
[23:22:52] 331 User cordless OK. Password required
[23:22:52] PASS (hidden)
[23:22:52] 230-User cordless has group access to: cordless
[23:22:52] 230 OK. Current restricted directory is /
[23:22:52] SYST
[23:22:52] 215 UNIX Type: L8
[23:22:52] Detected Server Type: UNIX
[23:22:52] RTT: 28.810 ms
[23:22:52] FEAT
[23:22:52] 211-Extensions supported:
[23:22:52] EPRT
[23:22:52] IDLE
[23:22:52] MDTM
[23:22:52] SIZE
[23:22:52] REST STREAM
[23:22:52] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[23:22:52] MLSD
[23:22:52] AUTH TLS
[23:22:52] PBSZ
[23:22:52] PROT
[23:22:52] ESTA
[23:22:52] PASV
[23:22:52] EPSV
[23:22:52] SPSV
[23:22:52] ESTP
[23:22:52] 211 End.
[23:22:52] Detected Server Software: PureFTPd
[23:22:52] PWD
[23:22:52] 257 "/" is your current location
[23:22:52] TYPE A
[23:22:52] 200 TYPE is now ASCII
[23:22:52] PORT 192,168,2,25,253,32
[23:22:52] 200 PORT command successful
[23:22:52] MLSD
[23:23:37] 425 Could not open data connection to port 64800: Connection timed out
[23:23:37] PASV
[23:23:37] 227 Entering Passive Mode (69,167,169,51,166,118)
[23:23:37] Opening data connection to 69.167.169.51 Port: 42614
[23:23:37] MLSD
[23:23:58] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[23:24:29] NOOP

------------------------------------------------------------------------------------------------------

Log from WS_FTP using PASV mode:

Finding Host 18cordlessdrill.org ...
Connecting to 69.167.169.51:21
Connected to 69.167.169.51:21 in 0.245000 seconds, Waiting for Server Response
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 23:16. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
Host type (1): AUTO
USER cordless
331 User cordless OK. Password required
PASS (hidden)
230-User cordless has group access to: cordless
230 OK. Current restricted directory is /
SYST
215 UNIX Type: L8
Host type (2): Unix (Standard)
Sending "FEAT" command to determine what features this server supports.
FEAT
211-Extensions supported:
EPRT
IDLE
MDTM
SIZE
REST STREAM
MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
MLSD
AUTH TLS
PBSZ
PROT
ESTA
PASV
EPSV
SPSV
ESTP
211 End.
Finished interpreting "FEAT" response.
Sending the FEAT command is optional. You can disable it in the site options of the profile.
PWD
257 "/" is your current location
TYPE A200 TYPE is now ASCII
PASV
227 Entering Passive Mode (69,167,169,51,171,228)
connecting data channel to 69.167.169.51:171,228(44004)
Failed to connect data channel to 69.167.169.51:171,228(44004)
PORT 192,168,2,25,252,149
200 PORT command successful
LIST
150 Connecting to port 64661
transferred 1643 bytes in 0.003 seconds, 4381.333 kbps ( 547.667 kBps), transfer succeeded.
226-Options: -a -l
226 22 matches total

mb

2010-11-20 05:02:45

Thanks. Did you add SmartFTP to the exceptions in your software firewall and antivirus product? E.g. try to temporary disable/uninstall firewall if SmartFTP is already in the firewall exceptions.

Khaldoun

2010-11-20 05:11:54

I don't think there is a need for this.
The reason I'm saying this?

Up till a week ago, I had a dedicated server with WiredTree and was always able to FTP to my sites without any problems.
It is since I moved over to this storm server that things went the way they are.

mb

2010-11-20 05:26:20

The primary problem is that the server you are referring to is not supporting passive mode (PASV) which it should. Hence you have to use active mode and therefore your nat router + software firewall has to allow the connection being routed to SmartFTP.

Khaldoun

2010-11-20 05:34:22

OK, but how can WS_FTP connect to the server then?
You will notice from the WS_FTP log it says the following:

"227 Entering Passive Mode (69,167,169,51,171,228)"

mb

2010-11-20 07:31:47

WS_FTP is not blocked by your software firewall. That is why you have to add SmartFTP to the exceptions in your software firewall product.

In the WS_FTP log you can see that passive mode (PASV) fails as well. WS_FTP then switches to active mode. But in this mode the server connects to your computer and therefore the ftp client needs to be in the exception list in your software firewall.

Khaldoun

2010-11-20 18:09:02

OK,
I've gone ahead and disabled my antivirus and my firewall completely.
Still no connection.

At this point I am not willing to spend any more time trying to get this software to connect to my server when another one will connect right out of the box.
Therefore please let me know how to go about getting a refund.

Thanks.

mb

2010-11-20 21:09:57

The connection is blocked by your software firewall or antivirus product. Try to uninstall your software firewall / antivirus product and then try again. The problem as we have seen numerous times in the past was never with SmartFTP.

Khaldoun

2010-11-21 00:13:13

My computer runs on Windows 7 Pro.
The firewall that I have is the Windows built-in firewall.
How do you propose I uninstall that.

Bottom line, I'm not going to go through hoops to make Smart FTP happy.
As far as I'm concerned, w works right out of the box under the same environment that Smart FTP will not.

Now, either I can get a refund or not.
Would like a clear cut answer to that.
No need to drag the situation any longer than that.