Transfer Queue freezes SmartFTP interface


When transfering files, if the "Transfer Queue" pane is open, SmartFTP will always stop responding. The window will show (not responding) on top, the interface freezes and the only thing I can do is close the program. If left alone, the transfer will continue, but there's no way to know when it's done. With the "Transfer Queue" pane closed, everything works fine as far as I can tell.

Here's the system info:
+- System -----------------------------

Microsoft Windows Vista Home Premium Edition 

Service Pack 2 (Build 6002)

CPU Speed           : 2605 MHz

Total Memory        : 1981 MB

Free Memory         :  884 MB

+- SmartFTP ---------------------------

Version             : 4.0.1054.0

Time Stamp          : 2009-10-06 19:54:07

Platform            : x86

Id                  : 400102263

Maintenance         : 2010-02-24

Days in use         : 518

+- Language ---------------------------


+- Internet Explorer ------------------

Version             : 8.0.6001.18813

+- Winsock ----------------------------

Winsock             : 2.2
This has been going on now for a few updates, so if there's a way to go back to a 2.x version with my current license, please let me know.



The dump file is 130MB in size

Please upload it to or to your server of choice.

Thank you. Did you take the process dump before the application hung or afterwards?

I'm not sure what you mean. I started SmartFTP, ran the command line provided and left the command window open, started a transfer with "Transfer Queue" open, the program hung, I closed the program and closed the command window in that order.

You should have run the command line after SmartFTP hang. Please try this:

1. Start SmartFTP
2. Start the Transfer Queue and make the application hang
3. Run the command line

The problem is with psicon.dll. This file comes from Adobe and is used to display thumbnails/icons for .psd files.

To disable it:
1. regsvr32.exe /u C:\Program Files\Common Files\Adobe\Shell\psicon.dll

2. Or go to the registry and delete the following keys:

3. Or rename psicon.dll to psicon.disabled.dll

Ok, I tried step 2. At first,it worked - before and after bootup. I then opened Photoshop and it recreated one of the registry entries causing SmartFTP to hang again, but this time on startup.

I went ahead and deleted the registry entry again and also renamed psicon.dll to psicon.old. Now everything seems to be working fine, although PSD icons now look like plain white files but I don't care. As long as SmartFTP stops hanging on me, I can live with it.

Thank you so much for your time and help.


Thanks for the feedback.

What version fo Adobe Photoshop are you using?


Thanks again, I have Photoshop version 7.0