Timeout, "Client Closed the Connection"

I have been having problems connecting to my ftp server for a while now. It appears to connect at first, but cannot open any of the domains or folders hosted on the server. I have downloaded the latest version of Smart FTP, by the way. Any ideas?

[16:37:14] SmartFTP v3.0.1026.3

[16:37:15] Resolving host name "ftp.adigitalcity.com"

[16:37:15] Connecting to 67.205.43.170 Port: 21

[16:37:15] Connected to ftp.adigitalcity.com.

[16:37:16] 220 DreamHost FTP Server

[16:37:16] USER (hidden)

[16:37:16] 331 Password required for (hidden).

[16:37:16] PASS (hidden)

[16:37:16] 230 User (hidden) logged in.

[16:37:16] SYST

[16:37:16] 215 UNIX Type: L8

[16:37:16] Detected Server Type: UNIX

[16:37:16] RTT: 80.147 ms

[16:37:16] FEAT

[16:37:17] 211-Features:

[16:37:17]  MDTM

[16:37:17]  REST STREAM

[16:37:17]  SIZE

[16:37:17] 211 End

[16:37:17] PWD

[16:37:17] 257 "/" is current directory.

[16:37:17] TYPE A

[16:37:17] 200 Type set to A

[16:37:17] PORT 192,168,0,100,10,156

[16:37:17] 200 PORT command successful

[16:37:17] LIST -aL

[16:38:17] Timeout (60s).

[16:38:17] Active Help: https://www.smartftp.com/support/kb/74

[16:38:17] Client closed the connection.

[16:38:17] Automatic failover of data connection mode from "Active Mode (PORT)" to "Passive Mode (PASV)".

[16:38:17] Resolving host name "ftp.adigitalcity.com"

[16:38:17] Connecting to 67.205.43.170 Port: 21

[16:38:17] Connected to ftp.adigitalcity.com.

[16:38:18] 220 DreamHost FTP Server

[16:38:18] USER (hidden)

[16:38:18] 331 Password required for (hidden).

[16:38:18] PASS (hidden)

[16:38:18] 230 User (hidden) logged in.

[16:38:18] SYST

[16:38:18] 215 UNIX Type: L8

[16:38:18] Detected Server Type: UNIX

[16:38:18] RTT: 80.233 ms

[16:38:18] FEAT

[16:38:18] 211-Features:

[16:38:18]  MDTM

[16:38:18]  REST STREAM

[16:38:18]  SIZE

[16:38:18] 211 End

[16:38:18] PWD

[16:38:18] 257 "/" is current directory.

[16:38:18] TYPE A

[16:38:18] 200 Type set to A

[16:38:19] PASV

[16:38:19] 227 Entering Passive Mode (67,205,43,170,210,93).

[16:38:19] Opening data connection to 67.205.43.170 Port: 53853

[16:38:19] LIST -aL

[16:38:19] 150 Opening ASCII mode data connection for file list

[16:38:19] 1587 bytes transferred. (14.2 KB/s) (109 ms)

[16:38:19] 226 Transfer complete.

[16:38:49] NOOP

[16:38:49] 200 NOOP command successful

[16:39:19] NOOP

[16:39:19] 200 NOOP command successful

[16:39:49] NOOP

[16:39:49] 200 NOOP command successful

[16:39:55] CWD /files.adigitalcity.com

[16:39:56] 250 CWD command successful

[16:39:56] PWD

[16:39:56] 257 "/files.adigitalcity.com" is current directory.

[16:39:56] PORT 192,168,0,100,11,23

[16:39:56] 200 PORT command successful

[16:39:56] LIST -aL

[16:40:56] Timeout (60s).

[16:40:56] Active Help: https://www.smartftp.com/support/kb/74

[16:40:56] Client closed the connection.

Hmm, it appears to work now, thanks! I'll let you know if difficulties continue.