Vista - Unable to launch

jamckin

2008-01-11 05:07:10

I have recently upgraded to Vista from XP, re-installed SmartFTP and it initially worked.

Went to use the FTP client this morning, and recieved an error: SmartFTP client has stopped working.
Microsoft's help suggests the installation of the patch from KB article 938979 - which does not install on my machine (This update does not apply to your system)

To try to rectify the problem, I have done the following steps:
Deleted the HKCU\Software\SmartFTP key
Uninstalled the application
Deleted the user files from C:\Users\Jim\Roaming\SmartFTP
Rebooted
Re-installed

Yet - I am still having issues running the application.

I have the errors as displayed in the event view pasted below. (Reading through the forums, I have tried two different installation files, as you can see here)

Old: 2.5.1008.27
Faulting application SmartFTP.exe
version 2.5.1008.27
time stamp 0x4763a929
faulting module ntdll.dll
version 6.0.6000.16386
time stamp 0x4549bdc9
exception code 0xc00000fd
fault offset 0x0006322c
process id 0x144c
application start time 0x01c8540ab902bc18.


Latest: 2.5.1008.29
Faulting application SmartFTP.exe
version 2.5.1008.29
time stamp 0x477c947c
faulting module ntdll.dll
version 6.0.6000.16386
time stamp 0x4549bdc9
exception code 0xc00000fd
fault offset 0x0006337b
process id 0xb54
application start time 0x01c8540bdf55b838.

mb

2008-01-11 05:36:10

Hello ..

You may want to try to delete the registry key again:
HKCU\Software\SmartFTP

If this doesn't help can you send us some crash reports? You can find some instructions on how to get them here:
https://www.smartftp.com/support/kb/how- ... f2594.html

Thank you for your time.

Regards,
Mat

jamckin

2008-01-12 01:03:15

mb

2008-01-12 03:37:40

Thank you. I got the dump. Unfortunately the stack seems to be corrupt/incomplete which makes it impossible to get anything useful out of it.

Try to run SmartFTP under a different user account.

Regards,
Mat

jamckin

2008-01-12 05:09:34

Mat,
I did as you suggested and created another user account, and the client ran correctly. :-)

For now it is a work around, would still like to get it running as my user though.

Cheers,
Jim

jamckin

2008-01-12 09:33:26

Mat,

Just to let you know - I managed to get it running again as my user, by restoring just the registry file from the backup.

The backup tool would not allow me to restore (Gave me an error restoring transfer queue.xml)

I extracted the registry file manually and merged, and I have a functioning client again.

However, when exiting, I now recieve a Microsoft Visual C++ Runtime Library Error. (The application has requested the Runtime to terminate it in an unusual way.)

All aspects of the client appear to be working correctly other than the error on exit.

Jim