Can't see text when managing or editing favourites in list view

When I click to edit / manage my favourites and I switch the display into list / details / tiles view, I can't see any of the text.

I can see the checkboxes & icons, but the text appears to be white. When I select a row, the row is highlighted in a background color and the white text can then be seen against the background.

I've tried other themes, however I get the same result.

When viewing in thumbnail mode, it works fine, however I prefer to use the detailed list display.

Here's a screengrab:

Any ideas would be appreciated.
Thank you.

Here's my system info:

+- System -----------------------------
Microsoft Windows Vista Ultimate Edition
(Build 6000)

CPU Speed : 1995 MHz
Total Memory : 2045 MB
Free Memory : 256 MB

+- SmartFTP ---------------------------
Version : 2.5.1008.40
Time Stamp : 2008-02-13 19:44:35
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
SmartHook.dll : File not found

+- Language ---------------------------
SmartFTP.exe : 2.5.1008.40

+- Internet Explorer ------------------
Version : 7.0.6000.16609

+- Winsock ----------------------------
Winsock : 2.2

Install SmartFTP from:

Then reboot your system. If you are advised to reboot and you don't you will see exactly what is on the screenshot.


I still don't have this issue fixed. I've been running a trial version and I won't buy this software if there is no fix to this issue. I have a large number of favourites that i need to manage.