IIS7 published ftp

IIS7 has integrated FTP such that FTP may be "published" to any hosted site. This allows an FTP client to connect to the site, with view only of the virtual directory supporting that site. Works well in case of many hosted sites.

SmartFTP is able to authenticate to this FTP site, which puts it ahead of IE and Windows Explorer! Following authentication, SmartFTP enters passive mode, and is unable to open a data connection at that point.

FTP from a command prompt works fine - and can upload / download data.

Is there a way to get this to work with SmartFTP?

Thanks, Cam

SmartFTP log:

[13:06:57] SmartFTP v4.0.1054.0
[13:07:04] Resolving host name "www.company.com"
[13:07:04] Connecting to Port: 21
[13:07:04] Connected to www.company.com.
[13:07:04] 220 Microsoft FTP Service
[13:07:04] USER www.company.com|userName
[13:07:05] 331 Password required for www.company.com|userName.
[13:07:05] PASS (hidden)
[13:07:05] 230 User logged in.
[13:07:05] SYST
[13:07:05] 215 Windows_NT
[13:07:05] Detected Server Type: Windows NT
[13:07:05] RTT: 23.280 ms
[13:07:05] FEAT
[13:07:05] 211-Extended features supported:
[13:07:05] LANG EN*
[13:07:05] UTF8
[13:07:05] AUTH TLS;TLS-C;SSL;TLS-P;
[13:07:05] PBSZ
[13:07:05] PROT C;P;
[13:07:05] CCC
[13:07:05] HOST
[13:07:05] SIZE
[13:07:05] MDTM
[13:07:05] REST STREAM
[13:07:05] 211 END
[13:07:05] OPTS UTF8 ON
[13:07:05] 200 OPTS UTF8 command successful - UTF8 encoding now ON.
[13:07:05] PWD
[13:07:05] 257 "/" is current directory.
[13:07:05] TYPE A
[13:07:05] 200 Type set to A.
[13:07:05] PASV
[13:07:05] 227 Entering Passive Mode (205,115,15,68,201,188).
[13:07:05] Opening data connection to Port: 51644
[13:07:05] LIST -aL
[13:07:05] 150 Opening ASCII mode data connection.
[13:07:26] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[13:07:43] 550 Data channel timed out.
[13:08:13] NOOP
[13:08:13] 200 NOOP command successful.

The better solution would be to setup the firewall rules (passive port range) for passive mode on the FTP server ;-)

The solution to the problem gets easier and easier - thank goodness for that! Yesterday the problem was so complex, based upon the hits I was finding.

I believe I am correct in saying that the root cause is simply that port 20 is blocked by the Windows 2008 firewall. Nowhere have I found mention of this as a problem, save mb in the post above!

I had looked at the firewall, but it says that FTP and FTP server are permitted. On the firewall advanced security gui, however, I found that only port 21 is allowed, port 20 is not. Fits the data! And not what I had assumed.

I have put way too many hours into this, having found the start of many answers and not the conclusion. so I will complete the story:

On the Windows 2008 server, Start; All Programs; Administrative Tools; Windows Firewall with Advanced Security. (Note this is not the same as the Windows Firewall interface on the Control panel.)

Continue to UAC; Select "Inbound Rules" in the navigation panel; examine existing rules. I found FTP and "FTP Server (FTP Traffic-In)", both allowing port 21. I found no rules for port 20.

Create a new rule. I named mine "FTP Data Port 20", selected Enabled, "Allow Connections", TCP port 20, remote all ports, set for any local IP address and any remote IP address.

With this done, my FTP client program connects just fine with default settings - and so using passive mode for data transfer.

Windows Explorer still does not work for me.

Hello ..

Allowing outgoing connections from Port 20 will only solve the active mode (PORT) issues.

For passive mode (PASV) you need to configure a port range in the FTP server's settings and enable this port range (incoming) in the firewall:
"Step 1: Configure the Passive Port Range for the FTP Service"
http://learn.iis.net/page.aspx/309/conf ... -settings/