SmartFtp crash at random using command line

Hi All,

I've used smartftp for a few weeks now and i really like it.. I want to purchase the software BUT i would really like the following problem fixed first as its driving my insain.

I use the command line within smart ftp to send raw ftp commands quite a bit.. At random when im typing a command in the client will freeze and i have to end task it..

I'm using version v3.0.1022.27 on Vista...

What should i do? Post a bug report?? How do i get debug information from the application in vista as it gives me no option?


If you can get a crash dump that would help a lot: ... f2594.html

The command described in the article above is used when SmartFTP crashes. If it hangs run the following command (after it hangs) instead:
"%ProgramFiles%\Debugging Tools for Windows (x86)\adplus.vbs" -hang -pn SmartFTP.exe -o C:\Dump


Also if you can tell use how to reproduce the problem it would be easier for us to fix it.

Ok, i think i've captured the crash..

I did the following..

I opened smartftp.. clicked on the command line and typed site who (that worked).. then typed site users (worked), then i started to type site reload.. As i was typing site reload smartftp froze.. I right clicked smartftp and forced it to close otherwise it will sit there forever frozen..

The dump is located here:

My sys info:

+- System -----------------------------
Microsoft Windows Vista Ultimate Edition
(Build 6000)

CPU Speed : 2492 MHz
Total Memory : 2047 MB
Free Memory : 1659 MB

+- SmartFTP ---------------------------
Version : 3.0.1022.27
Time Stamp : 2008-09-12 22:46:12
Platform : x86
Days in use : 121

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
sfFTPShellExtension.dll :
SmartFTPPS.dll : 3.0.1022.27

+- Language ---------------------------
SmartFTP.exe : 3.0.1022.27

+- Internet Explorer ------------------
Version : 7.0.6000.16643

+- Winsock ----------------------------
Winsock : 2.2

Hello ..
Thank you for the crash dump. I was able to load it but the stack trace is not very helpful:
> user32.dll!_NtUserGetMessage@16() + 0xc bytes
user32.dll!_GetMessageW@16() + 0x2b bytes
SmartFTP.exe!AfxInternalPumpMessage() Line 153 + 0xf bytes C++
SmartFTP.exe!CWinThread::Run() Line 629 + 0x7 bytes C++

SmartFTP receives a message in the message loop and calls GetMessage to get it and then the crash happens in the ndll.dll.

Can you try to install the SP1 of Windows Vista?


Sorry for the late reply, i was away for work..

Ive just updated to SP1 and it still crashs but not as oftern (i think anyway)..

I've uploaded new crash dumps here

Thank you but the dumps do not contain any crashes.

Can you please try the latest version from:


Can you tell us how to reproduce it?

I was finally able to reproduce it. The bug has been fixed in the latest version:

Please let me know if you find any futher problems.

Thank you.