SFTP over SSH (Server running Open SSH)

Hey SmartFTP,

I've been using the trial for a little while now and have loved the way SmartFTP helps my work flow rather than hinders it. I use tortoise SVN and it is absolutely invaluable to be able to see my file status, commit, update, and ftp all from the same window. I've recently been urged to start using SFTP by colleagues so I figured I'd do my part and buy a license for the new version which boasts SFTP support.

Initially I tried switching the favorite over to SFTP with no other real option changes and I got an "Incompatible SSH server running on host." error message. This initially caused some concern but I did what any reasonable software user should do and checked out your FAQs and Knowledge base. I was encouraged when I saw an article on utilizing SFTP over Open SSH but when I tried following the steps listed I hit a brick wall.

The third step instructs me to "Select Connection > Proxy. From the Proxy tab under the Type list select SOCKS4. Under the Settings you can set the proxy port to (e.g. 1080)". Under my "Type" drop-down I have these options available: "None", "SITE hostname", OPEN hostname", "USER user@host", USER fireID@host, USER user@hostFireID, USER user@FIreID@host, Transparent.

I didn't see a "SOCK4" option and am not sure how to proceed. Thanks for any insight into this problem as I would love to continue using SmartFTP but with a more secure transmission method.


hey mb,

Thanks for the quick support. By you asking me to send you the log, I was actually forced to read it and noticed the obvious error on my part: port 21. Obviously there is no SSH server there! Changed it to port 22 and everything is working great now. Gotta get used to some of the transfer queue and message changes but looks like I'll be able to enjoy smartFTP a bit longer