Help! Can't see folders/files on my server in FTP


I'm new here and have a BIG problem! I've been using Smart FTP for quite some time and have never had a problem with it. It's been great.

However, today I uninstalled a script I'd installed yesterday and tried to re-install it. I uploaded all of the files to my server and when the transfer was complete, I CANNOT SEE any of my files/folders in my public www directory! Furthermore, I'm unable to upload any files or folders.

I have no idea what the problem is, but it's a big problem since I can't continue to edit/update my site unless I can transfer files.

I should be able to see files/folders in my public www directory like cig-bin, fonts, images, pma, real audio, templates, wsusage, etc. But I can't see any of it. Instead, I see files under ftp.(mysite).com like backup, ftp, ftp2, ftp3, www, www2, www3, etc. None of it makes any sense. And when I click on the home or www folder, nothing shows. But I know the files are there. My home page (index.html) and other pages are there. I can pull them up by typing in the address in my browser.

I did download CuteFTP. I'm not familiar with it and have never used it, but when I open it up and look in my public www directory, I CAN see my site files and folders. Can anyone tell me what the problem is? When I uploaded the files and folders for the script, I wonder if something went wrong during the transfer or something. I'm not sure. There were no error messages and when I try to upload a file (ANYTHING!) my my site, it says unable to transfer.

Can someone help please? I have to be able to see the files that are there and transfer files to my site!


Michelle Nightengale

Hello MB,

Unfortunately, I'm not able to give you that. I wasn't sure what the problem was and I closed out SmartFTP before saving it. I still wasn't able to view the directory properly, so I un-installed and reinstalled Smart FTP.

Sorry about that.

I can tell you that when I open up SmartFTP, I see a bunch of fildes/folders under ftp.(mysite).com that weren't there before. And they do not match the files/folders that I see when I look at my public directory in my Web-based control panel for my site.

When I open up SmartFTP and look at the pane for my site, these are the files/folders listed under ftp.(mysite).com:

1. backup
2. bin
3. command
4. dev
5. etc
6. ftp
7. ftp2
8. ftp3
9. home
10. home2
11. home3
12. lib
13. library
14. lost+found
15. mnt
16. package
17. proc
18. root
19. sbin
20. service
21. tmp
22. tmp2
23. usr
24. var
25. www
26. www2
27. www3
28. wwws

Are there supposed to be 3 home folders and 3 or 4 www folders? I never noticed it before.

When I log into my site administration panel, I see these folders:

1. backup2
2. cgi-bin
3. config
4. css
5. fonts
6. images
7. js
8. lib
9. pma
10. prototype
11. realaudio
12. templates
13 wsusage

These are the folders (and their files) I'm familiar with. As you can see, the lists don't match! I'm not sure what the problem is. I'm also working with my Web host to resolve the problem, but the problem seems to lie with SmartFTP. For example, I downloaded CuteFTP just to see if I would encounter the same problem. But there I can see all of the files/folders.

By the way, I tried again the upload my index.html (home page) to the WWW directory and it seemed like it would let me because I got a pop up that said that file already existed and did I want to overwrite it? I said no and canceled the transfer. So SmartFTP sees the files of my Web pages there, but it doesn't display it in the pane!

I did double check to make sure passive mode is on as someone with my Web host suggested, and it is. I un-installed and re-installed SmartFTP as I said earlier, but I'm having the same problem.

I hope you can still help, even though I don't have the log. I'm sorry about that! But I'd really appreciate whatever help you can give me. As I said, I've never had a problem with SmartFTP before and I really like the program. But this has me baffled and it's a big problem.


Hello ..

Try the following:

1. Menu: File->New Remote Browser
2. Enter the host, username and password
3. Leave the Path input field empty
4. Click OK to connect

BTW: You can always get the log by connecting to the favorite/server again.


Hi MB,

Thanks so much for your help! Between you and my Web host, I was able to figure out the problem: I was starting in my site's root directory. When I started a new remote session (as you suggested) and typed in /home/(mysite) in the path, I was able to get to the directory I needed.

I greatly appreciate it. Have an awesome day!