SSH

SmartFTP 實現加密外殼(SSH)協議的下列功能.

功能

安全標準合規性

驗證

支援下列驗證方法::
  • 密碼
    使用者名稱/密碼和鍵盤交互驗證。同時支援伺服器密碼變更請求.
  • 公鑰
    金鑰檔案(PuTTY、VanDyke's SecureCRT、SSH.com、OpenSSH、PEM)、X.509 證書、來源於證書儲存或智慧卡的 Microsoft Windows 證書(PKCS #11).
  • Kerberos v5(GSSAPI/SSPI)
    支援 Microsoft Windows Kerberos(SSPI)和 MIT Kerberos(GSSAPI)實現.
  • 基於主機的
    使用主機金鑰檔案或證書的驗證.
  • RSA SecurID
    RSA SecurID 雙因素身份驗證。

加密

壓縮

金鑰交換方法

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

公開金鑰演算法

HMACs

擴展