SSH

SmartFTP реалізує наведені нижче функції протоколу Secure Shell (SSH).

Функції

Відповідність стандартам безпеки

Методи автентифікації

Підтримуються наступні методи автентифікації:
  • Пароль
    Автентифікація за іменем користувача й паролем та інтерактивна автентифікація з клавіатури. Також підтримуються запити сервера на зміну пароля.
  • Відкритий ключ
    Файл ключа (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), сертифікати X.509, сертифікати Microsoft Windows зі сховища сертифікатів або смарт-картки (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Підтримка для Microsoft Windows Kerberos (SSPI) та реалізації MIT Kerberos (GSSAPI).
  • На основі хоста
    Автентифікація за допомогою файла ключа хоста або сертифіката.
  • RSA SecurID
    Двофакторна автентифікація RSA SecurID.

Шифрування

Стиснення

Методи обміну ключами

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Алгоритми відкритого ключа

HMACs

Розширення