SSH

SmartFTP Secure Shell (SSH) protokolünün aşağıdaki özelliklerini barındırmaktadır.

Özellikler

Güvenlik standartlarına uyumluluk

Doğrulamalar

Aşağıdaki doğrulama yöntemleri desteklenmektedir:
  • Parola
    Kullanıcı adı/parola ve klavye-etkileşimli doğrulama. Ayrıca sunucudan parola değişikliği isteklerini de destekler.
  • Umumi Anahtar
    Anahtar dosyası (PuTTY, VanDyke's SecureCRT, SSH.com, OpenSSH, PEM), X.509 sertifikaları, bir sertifika mağazasından Microsoft Windows sertifikaları veya Smart Card (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Microsoft Windows Kerberos (SSPI) ve MIT Kerberos (GSSAPI) uygulamasını destekler.
  • Host Temelli
    Bir host anahtar dosyası veya sertifika ile doğrulama.
  • RSA SecurID
    RSA SecurID iki faktörlü kimlik doğrulaması.

Şifrelemeler

Sıkıştırmalar

Anahtar Değiş-Tokuş Yöntemleri

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Açık Anahtar Algoritmaları

HMACs

Uzantılar