SSH

SmartFTP ใช้คุณสมบัติของโพรโทคอล Secure Shell (SSH)

คุณสมบัติ

ปฏิบัติตามมาตรฐานความปลอดภัย

การรับรองความถูกต้อง

สนับสนุนวิธีการรับรองความถูกต้องต่อไปนี้:
  • รหัสผ่าน
    การรับรองความถูกต้องด้วยชื่อผู้ใช้/รหัสผ่านและแบบโต้ตอบผ่านแป้นพิมพ์ รวมถึงรองรับคำขอเปลี่ยนรหัสผ่านจากเซิร์ฟเวอร์
  • กุญแจสาธารณะ
    ไฟล์กุญแจ (PuTTY, VanDyke SecureCRT, SSH.com, OpenSSH, PEM), ใบรับรอง X.509, ใบรับรอง Microsoft Windows จากที่เก็บใบรับรองหรือสมาร์ตการ์ด (PKCS #11)
  • Kerberos v5 (GSSAPI/SSPI)
    รองรับ Microsoft Windows Kerberos (SSPI) และ MIT Kerberos (GSSAPI)
  • อิงตามโฮสต์
    รับรองความถูกต้องด้วยไฟล์กุญแจโฮสต์หรือใบรับรอง
  • RSA SecurID
    การรับรองความถูกต้องแบบสองปัจจัย RSA SecurID

การเข้ารหัส

การบีบอัด

วิธีแลกเปลี่ยนกุญแจ

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

อัลกอริทึมกุญแจสาธารณะ

HMACs

ส่วนขยาย