SSH

SmartFTP implementerar följande funktioner i protokollet SSH (Secure Shell).

Funktioner

Överensstämmelse med säkerhetsstandarder

Autentisering

Följande autentiseringsmetoder stöds:
  • Lösenord
    Autentisering med användarnamn/lösenord och interaktivt tangentbord. Även begäranden om ändring av serverlösenord stöds.
  • Offentlig nyckel
    Nyckelfil (PuTTY, VanDyke SecureCRT, SSH.com, OpenSSH, PEM), X.509-certifikat, Microsoft Windows-certifikat från ett certifikatarkiv eller ett smartkort (PKCS #11).
  • Kerberos v5 (GSSAPI/SSPI)
    Stöd för Microsoft Windows Kerberos (SSPI) och MIT Kerberos (GSSAPI).
  • Värdbaserad
    Autentisering med en värdnyckelfil eller ett certifikat.
  • RSA SecurID
    RSA SecurID tvåfaktorsautentisering.

Kryptering

Komprimering

Metoder för nyckelutbyte

  • diffie-hellman-group14-sha1 (RFC 4253) (for compatibility)
  • diffie-hellman-group-exchange-sha1 (RFC 4419) (for compatibility)
  • diffie-hellman-group-exchange-sha256 (RFC 4419)
  • diffie-hellman-group14-sha256 (RFC 8268)
  • diffie-hellman-group16-sha512 (RFC 8268)
  • ecdh-sha2-nistp256 (RFC 6239)
  • ecdh-sha2-nistp384 (RFC 6239)
  • ecdh-sha2-nistp521 (RFC 6239)
  • curve25519-sha256 (RFC 9142)
  • curve25519-sha256@libssh.org (for compatibility)
  • mlkem768x25519-sha256 (RFC 10042)

Algoritmer för offentliga nycklar

HMACs

Tillägg