Knowledge Base

Home > General > System Requirements

Created
Modified

Print Article

Article 7

System Requirements

To use SmartFTP, your system should be equipped with the following:

Supported Platforms

  • Windows XP SP3, 2003 SP2, Vista, 2008, 2008 R2, 7, 8, 8.1, 2012 (R2)
  • 32-bit (x86) and 64-bit (x64)

Other Requirements

  • Internet Explorer 8.x or higher
  • CPU supporting SSE2 instruction set (Pentium 4, Athlon 64 or higher)
  • 512 MB of memory (1 GB recommended)
  • 20 MB available disk space
  • Internet connection

Keywords
requirements

Related Articles


Please choose 1 to 5 whether this article solves your problem.

1 No Help at all

5 Problem Solved

Saving...
Thank you for your feedback.

What do you think about this topic? Send feedback!