Cannot add/edit favourites


I am using the 64 bits Version 3.0.1026.11 and I cannot add or change any favourites.
It just does not respond when I go to Favourites and try to add or edit.
Is there a workaround?
Here are my system/version specs.

+- System -----------------------------
Microsoft Windows Vista Business Edition
Service Pack 1 (Build 6001)

CPU Speed : 2133 MHz
Total Memory : 5054 MB
Free Memory : 2356 MB

+- SmartFTP ---------------------------
Version : 3.0.1026.11
Time Stamp : 2009-02-27 16:17:26
Platform : x64
Id : xxxxxxxxxx (removed)
Days in use : 684

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
sfFTPShellExtension.dll :
SmartFTPPS.dll : 3.0.1026.11

+- Language ---------------------------
SmartFTP.exe : 3.0.1026.11

+- Internet Explorer ------------------
Version : 7.0.6001.18000

+- Winsock ----------------------------
Winsock : 2.2

Hello ..

What exactly is not working? Are you able to opent he Favorites browser? Menu: Favorites->Edit Favorites.


Tom, I have the same issue with build .13.

Right click on a favorite (from favorites manager), properties - nothing happens. Click "New" and nothing happens.

There is also a blank menu entry when right clicking on a favorite (running SmartFTP on German OS).

Please close SmartFTP and then delete the old german language files *DEU.dll in the C:\Programme\SmartFTP Client folder.

Did that, I still can not add a favorite. The window just does not show. When I try to add a new folder SmartFTP crashes.

No change with build .14. To repro:

1. Open SmartFTP and click "Favorites" then "Edit favorites". Then right click on an entry and select "Properties" ("Eigenschaften" in my German OS). Nothing happens -> expected window to open.

2. Same as above but in favorites dialog on the right side where the favorites are, in a white area, do a right click and select New, Folder. SmartFTP crashes ungracefully.

3. Click on Favorites menu and then right click on a favorite, select "Properties", also here nothing happens.

1. Uninstall SmartFTP
2. Remove the complete C:\Programme\SmartFTP Client folder
3. Install SmartFTP.
4. Then try to run SmartFTP under a different user account

Also please check if you have a file called desktop.ini in the following folder:
%appdata%\SmartFTP\Client 2.0\Favorites

If yes delete it.


Uhm, would I not loose all my favorites?

Running under a different user account makes no sense.

This is a bug in the code, please fix it.

Please follow the instructions as given.

Please add your license key id to your profile in the forum.

Another fix that worked for another user was to delete the registry key at:

1. Go to the start button in Windows (bottom left)
2. Select Run...
3. Enter regedit.exe
4. Press Enter
5. Delete the registry key/folder at:

I tried that, does not work.

I still can not add or edit favorites. In the favorites window when I right click and select "New", "Folder" then SmartFTP crashes. I have Vista-32 with SP1.

Can't you repro this, it repro's here every time no matter what you tell me to do.

Nope we cannot reproduce it otherwise the problem would not exist. We had a couple of users with the same problem and it all orginated from old localization files (*DEU.dll), a corrupt installation or a registry problem.

Did you try everything I suggested?
1. registry cleanup
2. complete uninstall with manual deletion of all files in the program files folder
3. rename the %AppData%\SmartFTP folder to %AppData%\SmartFTP.Backup



I took a copy of the favorites folder and then removed the registry key, uninstalled SmartFTP and rebooted. I then manually deleted all folders, also the one in appdata/roaming.

I then re-installed latest 3.0 and voilá I can now edit favorites. However for some reason the copied favorites folder was empty and I now have to re-enter all my favorites. The favorites backup is something you guys need to look at (perhaps offer a server based option like Foxmarks for Firefox?).

Still very puzzeling why a complete uninstall is required to get SmartFTP working again...

The favorites in SmartFTP are individual .xml files. So you can just copy the xml files/folders from your old favorites folder to the new favorites folder.

You can do daily/weekly backup of your favorites. Menu: Tools->Settings. Then go to the Backup page.


OK, I'll take a look at that.

Any idea why a complete uninstall/re-install was required to get rid of the non functional favorites issue and crash when adding a new favorite?


My problem with the favourites on Vista 64 is solved, doing what you suggested:

- start windows vista in safe mode
- delete smartftp registry keys with regedit (hkey_current_user\software\smartftp)
- delete old program files in program files (x86)/Smartftp
- rename users\your_username\AppData\Roaming\Smartftp into Smartftp.backup
- reboot to windown normal mode
- reinstall
- unzip your favourites backup and place them into your appdata smartftp favourites folder

Thank you for your support.

best regards,


tom, I have the same problem (I think) but your solution did not work for me.

did you have problem renaming favourites both in the favourite manager and in the favourite menu?

tom, I have the same problem (I think) but your solution did not work for me.

did you have problem renaming favourites both in the favourite manager and in the favourite menu?

No, not with renaming the favourites; I just couldn't change the properties or add new ones.
Your problem sounds different, but I am no expert...

danifer: Try to remove/rename the Favorites folder.

I did that too. Without success.

danifer: Try to remove/rename the Favorites folder.

I can gladly confirm that this issue is fixed in the latest build (v3.0 Build 1026.18).