download arrow not visible

selecting a file or folder does not enable the download arrow. I downloaded the latest version of 3 a few night ago and installed it and the upload download arrows were present but as of today neither were present. I downloaded the last build and after the install the upload arrow is enabled when I select a file or folder but the download arrow is still not visible.

Also, then I upload something or download and it goes to the queue it does one file every minute or or longer and on big uploads it can take hours. I have tweaked the speed and workers to no avail. Also when I upload files that need to overwrite the old the copy and write over doesn't keep working it pops a box up each time no matter what you check and ignores and auto settings.

A lot of bugs with the queue and uploading and downloading....

I have also just uninstalled and deleted all of the folders for smartftp in program files and in application data then reinstalled but still same issues.

Here is the system info:

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2210 MHz
Total Memory : 2047 MB
Free Memory : 1389 MB

+- SmartFTP ---------------------------
Version : 3.0.1021.7
Time Stamp : 2008-07-30 04:23:37
Platform : x86
Id : 400035161
Days in use : 345

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
sfFTPShellExtension.dll :
SmartFTPPS.dll : 3.0.1021.7

+- Language ---------------------------
SmartFTP.exe : 3.0.1021.7

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

I will just have to go back to 2.5 for now until the bugs are worked out of this version. If I had known it was so raw I would never have upgraded at all. I cannot afford this kind of down time right now.

Matt I posted in premium too since I have about 20 days left on my year that I have not ever used no replies yet though...

I'm closing this. It's a duplicate. You posted the same problem into the premium support forum.