Renaming a local file a second time doesn't work in 3.0.1019.11

I renamed a local file in the left screen. That worked. I even checked in Windows explorer. It was renamed. All well and good so far.

Then I changed my mind (oh dear!) and decided to call that file something else completely.

I pressed F2 with the renamed file highlighted.

The highlighted name changed to the original (pre-renamed) filename.

Ignoring that, I renamed it again anyway.

Sadly, that didn't work - an error said the file didn't exist (I assumed a file with the pre-renamed name):
Error renaming file or folder
Cannot rename file: Cannot read from the source file or disk

Sometimes, pressing the recycle/refresh icon worked around the problem - after pressing it, I could rename the file again.


Please install the latest version from:

Then post the system information from the menu: Help->About "System Information" dialog.

Did you rename a folder or a file? Because the tree on the left side on displays folders?

Thank you.