SmartFTP does not load up at all

hi there!

I've been running 2.5 for a long time now without any hassles but as soon as I upgraded to ver3 it refuses to load up at all.

I completely uninstalled 2.5 + rebooted before installing 3 (3.0.1018.1). I also tried the beta version of 3 (3.0.1018.3) - (As well as the 64bit vers but those complained I'm not running 64bit XP).

I am running a 64bit CPU but only 32bit XP. I've tried disabling DEP too.
AMD Athlon 64 X2 Dual Core 3800+
2gb ram
Windows XP SP2

after it installs I try open it and I get no response at all. No errors messages, no background task in task manager or anything. Mouse cursor says busy for a second or two then nothing.

I tried the crashdump too but that also seems to not be very useful. (I installed version of the ms debugger)

C:\Program Files\SmartFTP Client>cscript "%ProgramFiles%\Debugging Tools for Windows (x86)\adplus.vbs" -crash -FullOnFirst -pn SmartFTP.exe -o C:\Dump

Microsoft (R) Windows Script Host Version 5.6

Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

C:\Program Files\Debugging Tools for Windows (x86)\adplus.vbs(2191, 4) Microsoft VBScript runtime error: Invalid procedure call or argument: 'Right'

C:\Program Files\SmartFTP Client>

Try to delete the registry key at:
using regedit.exe