Changing Folder adds / automatically


I am using SmartFTP. On our University, we can access the Novell network via FTP. To change to the right Server I have to enter the directory \\servername. In Version 2.5 everything works fine, SmartFTP sends the command cwd \\servername. But in version 3.0 Smartftp sends the Command cwd /\\servername. The server can not be found because of the /. In my case smartFTP ist unusable. :-(
Please help me and fix this "bug"!

Edit: Even if I use \\servername as path in the favorites-properties, SmartFtp adds the / to the cwd command.


Please post the log of your FTP session.


Hello mb,

I tried both way. Entering the path manually works fine in version 2, but not in version 3. The same problem with the favorites.
Path ist set to \\fh-kroesus\DATA1\kurs, in version 2 this also workes fine...

According to the Novell documentation you can use replace all \ with /.

URL: ... ml#a2fbytk

3.2.3 Accessing a Remote Server

To navigate to remote servers, use the following format: 

cd //remote server name/volume/directory pathname

File operations such as get, put, and delete can be used on the remote server, even without changing directory path to that server. For example:

get //remote_server_name/volume/directory path/filename

The double slash (//) indicates that the user wants to access a remote server. After the double slash, the first entry must be the name of the remote server.

Thank you for your help.

I tried //fh-kroesus/DATA1/kurs but Smartftp only sends one /

[19:44:36] CWD /fh-kroesus\DATA1\kurs
[19:44:36] 550 Invalid Path

Hello ..

Well the whole design with the remote server in path is very bad. The server should at least return the //remote server part in the PWD command. If the remote server is not part of the path how is the FTP client supposed to know on what remote server the files are located at?

You can manually edit the Transfer Queue items. To do this stop the transfer queue. Then right click on the item you want to edit and select Properties from the context menu. Then start the queue. This might work but once again since this path system is totally flawed you will always run into problems.


Working on a workaround for this server. Please post here if you are interested to test it.