Class not registered error

We recentily purchased a license for the library, and we managed to use this on our development box, however when moving across the our production environment, we get this error:
Retrieving the COM class factory for component with CLSID {52D6E699-9256-414F-8FCD-F38FDF6AC8EE} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
Any ideas what might fix this.

regsvr32 sfFTPLib.dll
Or alternatively (better solution) if you build the executable, use SxS. Add the following to the manifest in the .exe:
            processorArchitecture="*" />
Documentation: ... ution.html

We're running this through a class library in a web service backend, so I don't think this really applies (there are no exe's).

Then the first option applies:
regsvr32 sfFTPLib.dll

I've tried the first option running this in command prompt in admin mode (with the dll in system32 and in SysWOW64 directories), running the regsvr32 from each of those directories respectively, but I keep getting the error:

The module "sfFTPLib.dll" failed to load.
Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependant .DLL files.
The specified module could not be found.
Am I missing a dependency?

vcredist_x64 has already been installed, and the dlls are included, but we are still getting the same error. This is on Windows server 2012 R2 (64bit). Is there anything else I could be missing?

Did yo copy the MUI folder en-us as well? The folder structure (en-us) must be retained.

MUI file and folder copied as well, still the same error.