Topfield ftpd PWD problem

tonymy01

2005-07-08 11:10:19

I am having nearly the same problem as https://www.smartftp.com/forums/director ... b52902f8e0 (no directory listing shows in the gui, but "raw directory listing" shows correctly), worked fine with the older version I was running (not sure now I have upgraded) and doesn't show any directory listing for 1.5.988

Here is a typical login:


220 SLUG FTP server (Topfield ftpd 0.5.2) ready.



    USER anonymous



331 Guest login ok, type your name as password.



    PASS (hidden)



230 Guest login ok, access restrictions apply.



    SYST



215 UNIX Type: L8 Version: Linux 2.4.22-xfs



    TYPE I



200 Type set to I.



    REST 0



350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.



    PWD



257 "" is current directory.



    CWD /



250 CWD command successful.



    PWD



257 "" is current directory.

And here is a right click raw list


drwxr-xr-x   1 none none            0 Jan  1 2003  DataFiles



drwxr-xr-x   1 none none            0 Jan  1 2003  EPGdata



drwxr-xr-x   1 none none            0 Jan  1 2003  EPGdataI



drwxr-xr-x   1 none none            0 Jan  1 2003  ICEdata



drwxr-xr-x   1 none none            0 Jan  1 2003  MP3



drwxr-xr-x   1 none none            0 Jan  1 2003  PlayLists



drwxr-xr-x   1 none none            0 Jan  1 2003  ProgramFiles



-rw-r--r--   1 none none          512 Jan  1 2003  PBKLicence.txt



-rw-r--r--   1 none none          512 Jan  1 2003  PBKLicenceKey.txt



-rw-r--r--   1 none none          454 Jul  3 2005  TEDSfavourites.tsv



-rw-r--r--   1 none none           86 Jul  3 2005  tedtest.tmp

I am gathering it is because the ftpd-topfield (daemon used to communicate to a Topfield set top box) uses "windows" style "" rather than "/" but the older SmartFTP didn't have any issues with this.

edit:
aha, was able to semi-install the old version (few probs now with it though, but enough to tell you the version and that it works):

Regards
    SmartFTP v1.1.985.6



    Resolving host name slug...



    Connecting to (slug) ->  IP: 192.168.0.102 PORT: 21



    Connected to (slug) -> Time = 94ms



    Socket connected waiting for login sequence.



220 SLUG FTP server (Topfield ftpd 0.5.2) ready.



    USER anonymous



331 Guest login ok, type your name as password.



    PASS (hidden)



230 Guest login ok, access restrictions apply.



    SYST



215 UNIX Type: L8 Version: Linux 2.4.22-xfs



    TYPE I



200 Type set to I.



    REST 0



350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.



    PWD



257 "" is current directory.



    Compression disabled for private IP addresses.



    PASV



227 Entering Passive Mode (192,168,0,102,6,146)



    Opening data connection IP: 192.168.0.102 PORT: 1682.



    LIST -a



150 Opening BINARY mode data connection for 'file list'.



    698 bytes received successfully. (698 B/s) (00:00:01).



226 Transfer complete.
edited again to make thread make a bit of sense with reference to orig problem.
Regards, and thanks for your solution!

mb

2005-07-08 14:45:12

Both server are not UNIX compliant but they claim to be in the SYST reply. One doesn't return an absolute path, the other one returns the wrong path delimiter.
Nevertheless we will write a work around for such situations.

Regards,
-Mat

mb

2005-07-08 22:52:43

Please download and install the latest beta build.
https://www.smartftp.com/download

It works around the problem with the Topfield ftpd server only.

Regards,
-Mat