Unable to connect to Server

SmartFTP v1.1.984.18
Resolving host name ftp.ashenempireshq.com...
Connecting to (ftp.ashenempireshq.com) -> IP: PORT: 21
Connected to (ftp.ashenempireshq.com) -> Time = 0ms
Socket connected waiting for login sequence.
Cannot login waiting to retry (30s)...

This is not due to a firewall problem since I had the firewall active on the computer back when I was able to successfully connect.

Hello ..

Please see this article:

To make sure its not your firewall software. Stop the services and uninstall any software which hooks itself into the winsock layer. e.g. software firewall, spyware realtime check, etc.


I already tried shutting down both firewalls and the spyware finding program as well as the antivirus protection and all other non-essential internet enabled software.

This still did not correct the problem. I also did a remote assistance session with the administrator of the server I use and he was unable to find any problems. The only thing he could say is that it looked like a router problem. But seeing as how the router has not been changed hardware or software wise, it was highly unlikely it was the problem.

Okay, I called up Alienware Tech Support and they say that the most likely cause is due to some sort of buffer that wasn't resetting properly under Win XP SP2 and that this causes the problem to not occur for sometimes several months. Because of this, they recommended that I contact you to ask you about making a patch to make SmartFTP SP2 compliant.

If you would like to go to the page where the SP2 program non-compliance list is at, you can go to www.alienware.com, then click support, then knowledge base. Then under search by, change that selection to by ID number and enter 2736.

Hello ...

SmartFTP is fully compliant with SP2. If you get other information, they are wrong.

Well, until I get further information on the problem showing to the contrary, I would have to believe what they are saying. This being because I actually saw your other major competitors (CuteFTP and WS FTP) listed there as well. If it will help, I am willing to do a remote assistance session with you so that you can diagnose the problem.

In the end, I just want to be able to get the problem fixed so that I can connect to my site's server.

I can connect to the server without any problems.. so the problem has to be on your end.

Hi Falconwing, try searching for alg.exe on your task manager. if it's there kill it and try connecting again. If it works, go to control panel, Administrative Tools, services and search for application layer gateway service, double click on it and change the startup type to disable.

Well, I did have alg.exe in there and I killed it and tried connecting, but it still didn't work with the same problem again.

i also can connect to the server without any problems. as the server's admin already assumed, this seems to be a router / firewall configuration problem on your side.

How can it be a router/firewall configuration problem when I hadn't changed the settings of it? I was connecting just fine with the same settings before that I have right now.

Okay, I had another thought about what the problem might be and checked the windows updates in add/remove programs list. I saw one update from the 23rd of february, which is about the same time that my problems began. Unfortunately, I neglected to record the ID of the update that was the cause of the problem.

Right now, I am re-updating the system with the 3 updates I removed, doing them one at a time, restarting after each one to determine which one caused the problem.

The three updates I am reapplying are:

KB867282: Security patch for IE
KB891781: Security update for XP OS
KB887742: Update for XP OS

Okay, I narrowed the problem down to the IE patch. It is the only one now that I do not have installed and my FTP software is functioning normally.

It's quite strange i have that patch instaled and SmartFTP works fine.

Well, I contacted Microsoft about the problem with the patch and they are going to check what caused the problem from it.

Just curious, what OS are you running on Aokromes? I'm using XP Home SP2

XP pro sp2.

Interesting. Maybe there are some networking files in Pro that Home would need with that patch in order to allow SmartFTP to continue functioning properly.