No FTP access with Norton Internet Security 2005

ggordon

2004-11-10 16:46:41

I have just upgraded from NIS 2004 to 2005 and SmartFTP cannot access my servers unless the Personal Firewall is disabled. I have exhausted Norton's suggestions (and SmartFTP Knowledge Base suggestions) with no change. Among other things, I have created manual rules to allow access on ports 20 and 21, but nothing seems to help. Norton Tech Support has asked me to gather information on SmartFTP's executable file, the ports and services it may use, the addresses it may access, and the protocols it uses in its communications.

Has anyone run into this problem?

Thanks,
Glenn Gordon

mb

2004-11-10 19:45:35

Hello ..

You need to add SmartFTP to the "allowed application list" in the Norton firewall settings. The howto at
https://www.smartftp.com/support/howto
should give you directions on how to do it.

We will test the latest NIS 2005 with SmartFTP to make sure it works.

As far as I know manual port configuration shouldn't be necessary.

Regards,

ggordon

2004-11-11 13:32:16

Hi Mat,

Unfortunately, I have been through that procedure several times without success. Running Program Scan adds SmartFTP automatically and I have done it manually as well, but nothing has worked so far. As I mentioned, Norton Tech Support has basically given up. I hope your check with NIS 2005 will shed some light on what needs to be done.

Thanks,
Glenn Gordon

Aokromes

2004-11-11 14:50:04

Hi, i have tested SmartFTP build 983.7, 983.13 and 983.15 with NIS 2005 and it worked without trouble.

mb

2004-11-11 17:03:31

Did you try to uninstall and reinstall the NIS 2005?

We cannot really recommend norton security products. They tend to cause problems with lots of software products.

ggordon

2004-11-12 03:25:07

Interesting to know that it works normally for someone. I also have Ace FTP installed and it is equally unable to make connection unless NIS is disabled. I haven't tried the uninstall/reinstall route but may be forced to give it a try. I have used Norton for several years with no problems.

Thanks for all your help.

Glenn Gordon

Noutje

2004-11-16 12:52:14

It seems NIS 2005 has problems in recognizing services needed by FTP programs. I have the same problem with various FTP programs. I completely removed NIS2005 and tried CA EasyArmor. This firewall also gave problems on FTP programs but when i placed the ftp server adres in the trusted zone it worked. I removed CA EasyArmor Again en reinstalled NIS 2005 en allowed all connections from en to the ftp server and put them in the trusted zone but with NIS 2005 it still did not work. With several reinstallations the problem still exists.

mb

2004-11-21 12:52:13

Hello ...

Noutje posted a solution into another forum:
https://www.smartftp.com/forums/viewtopic.php?t=8161

Hope this helps.
-Mat

katubris

2005-09-22 11:24:04

I experienced the same trouble few days ago...upgraded from NIS2004 to NIS2005 and the SMARTFTP software together with any other FTP software don't work anymore !
I tried everything ! Starting from the instructions i found on official symantec web site.

This is VERY BAD, considering NORTON a primary worldwide known SW HOUSE,i think they should at least suggest a pale idea about what doing positive in order to solve this clear problem.

In case i got the right solution (..let's hope 4 the best ) i will send it right back to you.

Best wishes with NIS2005 !

gnade

2005-10-01 00:45:00

Prior to version(s) 1.5, Smart FTP worked fine with Norton Internet Security 2005. So, the problem I am having wasn't created by Norton but by SmartFTP. I've tried all the suggestions posted here to date without success. The only way 1.5 works is by disabling Norton 2005. -- Gerhard

mb

2005-10-02 06:07:12

The problem is not with SmartFTP. It's with Norton's products as proofed numerous times in this forum and all over the world :-)

As a reminder, please do not post into this forum without providing your license key and especially not when making false statements.

Thank you.

-Mat

gnade

2005-10-03 16:25:34

The problem is not with SmartFTP. It's with Norton's products as proofed numerous times in this forum and all over the world :-)

As a reminder, please do not post into this forum without providing your license key and especially not when making false statements.

Thank you.

-Mat

Mat,
I did not mean to make false statements; I only described what MY experience was: ...SmartFTP worked just fine AFTER I installed NIS 2005. It was AFTER I upgraded to SmartFTP1.5 that I had the problem. So what am I to conclude? Also, some comments in this Forum appear to contradict your assertion about the proof that the problem is with Norton.
Best, Gerhard

My license key is 400000461
Systems Info is:
+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1593 MHz
Total Memory : 490988 KB
Free Memory : 171912 KB

+- SmartFTP ---------------------------
Version : 1.5.990.13
Time Stamp : 2005-09-23 05:38:58

+- Application DLL --------------------
Controls.dll : 1.6.990.13
sfFTPLib.dll : 1.5.7.0
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 1.5.990.13

+- System DLL -------------------------
shell32.dll : 6.00.2900.2620 (xpsp_sp2_gdr.050225-1820)
shlwapi.dll : 6.00.2900.2713 (xpsp_sp2_gdr.050702-1513)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll : 5.30.23.1221
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

mb

2005-10-03 17:21:22

Hello.

Thanks. Please try the following solutions:

- https://www.smartftp.com/forums/viewtopic.php?t=8161

- Disable XP SP2 firewall if enabled. It seems to be a problem to run 2 software firewalls at the same time.

- Disable NIS 2005

Oh btw please think about the following implication you made earlier:
Situation T0: SmartFTP 1 + NIS 2005 => Works
Situation T1: SmartFTP 1.5 + NIS 2005 => Doesn't work
=> SmartFTP 1.5 is the cause
This is only true if SmartFTP 1.5 and NIS 2005 are totally independent. As this is not true in reality the implication is wrong.

-Mat

Aleverde

2006-01-16 09:28:35

Aleverde

2006-01-16 09:47:52

Update: Noutje's solution works and rocks!
Thank you Noutje!
The link to his solution given by our Euskal developer does not work; the correct link is this one: https://www.smartftp.com/forums/index.ph ... entry32598

rubeus

2006-05-14 17:06:50

druekberg@msn.com

2006-07-05 04:07:22