Bug? Cannot connect to Drive F:

sakaasa

2004-11-10 10:01:52

Received an email about an upgrade release. I downloaded the msi and installed the new 1.0.983 update. At the end of the install, a dialog said that my license had expired. I used the more about link in the dialog box and purchased the 3yr upgrade.

Once the email arrived, I clicked ok on the open dialog, then exited SmartFTP. I then copied the license exe to the program catalog, the ran the license exe.

Now everytime I open Smart FTP, I get the error message: "Cannot connect to Drive F:"

Drive F: is my CD-Rom drive. Smart FTP has always been installed from the a website download on hard drive (volume E). System is Win2000Pro, SP4, IE6.

SmartFTP now at the latest version (1.0.983) and the license is installed correctly.

So, how do I get rid of the error message? :roll:

Thanks

mb

2004-11-10 19:46:47

Hello ...

Do you have any "Localbrowser" windows open in SmartFTP before you close the application? If yes, close them (Menu: Window->Close All) before you exit SmartFTP.

Regards,

sakaasa

2004-11-10 20:22:08

Closing the local browser worked.

I still think it is a bug. The browser was open to the hard drive, not the CD-Rom drive. The problem never occured until I installed the latest upgrade.

Thanks for the quick response

mb

2004-11-10 20:34:46

The "Localbrowser" saves the current/working folder before its being closed. When you restart SmartFTP, the "Localbrowser"s get restored including the current/working folder in each of them. If you working folder was the CD drive and the CD drive is empty, you will the same message as you would in the MS Explorer too.

I think the behavior is correct.

sakaasa

2004-11-10 21:01:17

Yes - I would agree except the browser and working folder are not the CD or the CD drive. Besides. There is a CD in the F: drive, but the is no local browser window opened to that drive. So - why does it give the error message??

Also, I have had the same local browser window open for the last month, using SmartFTP everyday. Also, I have been closing and reopening SmartFTP everyday with the local browser window open.

No problem until the last upgrade.

So why wasn't it a problem before the upgrade if the behavior is correct now?

Sharon

mb

2004-11-10 21:34:08

I dont know what version you had installed before. There are several system settings which may affect it as well. Thus I cannot make any statements why the problem didn't occur before.

The way I can reproduce the "problem" is exactly how I described it before. Open the localbrowser, select the CD drive in the treeview and close SmartFTP. This makes me think that the current/working folder in your Localbrowser was the CD drive.

All user who reported the same/similiar problem solved it by changing the default/current/working folder in the Localbrowser.

-Mat

sakaasa

2004-11-10 21:40:58

I am not arguing with you. No need to. Just took the time to report a problem and I gave you the correct info.

I update each time a new update is available. I know what drive I had open in the browser window. After all, I have been building PCs since the 1980s.

Sharon

mb

2004-11-10 22:28:51

Hello ...

I'm not arguing with you either :-) It's not that I dont believe you, but I tried to explain why it's hard for us to find the bug and to solve the problem without being able to reproduce it.

We really appreciate your bug reports. Thank you for the time to write them and for your prompt answers :-)

Thanks