Following Default Browser Settings

SmartFTP does not seem to be looking at the default browser settings in Windows XP. For example, with the new License Reminder dialog if you click on the link it brings it up in IE even though my default browser if Firefox.



I recently had a similar issue, Firefox doesn't register itself correctly as the default browser. Or more precisely: Some browsers (i.e. MyIE2) have an unusual way of registering themselves, and Firefox can't cope with that. Be sure your registry keys basically (I removed some stuff) look like this:

@="URL:HTTP (HyperText Transfer-Protokoll)"






It's important that the default keys unter "httpshell" and "httpshellopen" are empty! Same goes for the "https" protocol.

I did look there and everything seems fine. Plus most other apps (all except SmartFTP I think) seem to bring up Firefox, even from similar hyperlinks embedded in a windows dialog.


Hello ...

We use the MS HTML control in the new dialogs. I guess this control opens Internet Explorer for all links.

For links embedded in other dialogs (Settings->Transfer->ASCII) it opens the link with the shell "open" command. Thus the default browser should open the link.