Cannot establish connections since installing XP SP2

After installing XP SP2 I could no longer log into FTP sites with SmartFTP v1.0.983. I added SmartFTP to the Windows Firewall Exception list. However, it did not help. I finally stopped a service called "Application Layer Gateway Service." Then I was able to connect to an FTP site with SmartFTP. Now what? Application Layer Gateway Service normally starts automatically. Should I leave it this way because it is needed for other connection functions and just disable it when I need SmartFTP or should I disable it entirely. Please comment. I also have a Watchguard VPN client running on this computer.

Hello ...

Get the latest SmartFTP build:

then delete all exceptions in the XP firewall settings. SmartFTP will automatically prompt you when it tries to make a PORT connection.

If you stop the Application Layer Gateway, the XP SP2 firewall is disabled which is probably not what you want.

There are no problems with SmartFTP and the XP SP2 firewall. The XP SP2 is ONLY blocking incoming connection, outgoing connections are going through just fine (by theory at least) :-)

Another firewall software running on your system might be blocking SmartFTP.


Hi Mat,

I downloaded and installed the latest build. I also deleted SmartFTP as an exception in the XP Firewall. Then I restarted Windows. However, I still could not log into my FTP site. It connects but will not log. SmartFTP did not prompt me when it tried to make a port connection (Port 21). I am not running any other firewall program. Any further ideas?