Problems with SmartFTP Secure FTP (TLS-C) through proxy

jrdepriest

2004-02-03 20:55:43




+- System -----------------------------







Microsoft Windows 2000 Professional 



Service Pack 4 (Build 2195)







CPU Speed         : 996 MHz



Total Memory      : 392688 KB



Free Memory       :  73732 KB







+- SmartFTP ---------------------------







Version           : 1.0.980.1



Time Stamp        : 2003-12-13 01:25:08







+- Application DLL --------------------







controls.dll      : 1.6.980.1



ftpapi.dll        : 2.0.980.1



language.dll      : 1.0.980.1



reseng.dll        : 1.3.980.1



smarthook.dll     : 1.0.2.1







+- System DLL -------------------------







shell32.dll       : 5.00.3700.6705



shlwapi.dll       : 6.00.2800.1276



comctl32.dll      : 5.81



riched20.dll      : 5.30.23.1215



schannel.dll      : 5.00.2195.6705







+- Internet Explorer ------------------







Version           : 6.0.2800.1106







+- Winsock ----------------------------







Winsock           : 2.2




I am trying to connect to an AIX system running Connect:Enterprise with the Secure FTP option enabled.
My Internet connectivity is through a proxy server and firewall.
The proxy server support SOCKS5 (which is what I am using) and the firewall requires using PASV for FTP traffic.

I am able to connect to the remote system, but something strange happens with the key exchange and then I get disconnected before I can perform any file transfer actions.

Here is a (sanitized) log:



***********************************************************************************************



*          SESSION STARTED AT 03.Feb.2004 14:40:50



***********************************************************************************************







    Resolving host name proxy.domain.com...



    Resolving host name 111.222.333.444...



    Connecting to Proxy (proxy.domain.com) ->  IP: AAA.BBB.CCC.DDD PORT: 1080



    Connected to Proxy (proxy.domain.com) -> Time = 0ms



    Socket connected waiting for login sequence.



220 <<<Connect:Enterprise UNIX 2.1.00 Secure FTP>>> at ftbce02 FTP server ready. Time = 14:43:47



    AUTH TLS-C



234 AUTH TLS-C/TLS OK.



    PBSZ 0



200 PBSZ 0 OK.



    USER test



331 Password required for test.



    PASS (hidden)



230 Connect:Enterprise UNIX login ok, access restrictions apply.



    SYST



215 UNKNOWN Type: L8



    REST 100



550 Operation is not supported under Connect:Enterprise FTP server.



    TYPE I



200 Type set to I.



    REST 100



550 Operation is not supported under Connect:Enterprise FTP server.



    PWD



257 "/test" is current directory.



    TYPE A



200 Type set to A.



    PROT P



200 PROT P OK, data channel will be secured.



    PASV



227 Entering Passive Mode (192,168,248,27,33,103)



    LIST -aL



    Opening data connection IP: 192,168,248,27,33,103 PORT: 8551.



    SSL Error



    The operation completed successfully.



    Connection closed. Server timeout.



    NOOP



    Command aborted by user.







***********************************************************************************************



*          SESSION  CLOSED AT 03.Feb.2004 14:42:40



***********************************************************************************************




It doesn't appear to show up in the log, but the remote port I am connecting to is 20021 instead of 21.

mb

2004-02-04 01:12:51

It seems to be an incompatibility between SmartFTP and the AIX FTP server.

Have you created and selected a self signed cert under Menu: Tools->Settings->SSL?

We can debug the problem if we have FTP access (read only would be sufficient) to the server. Otherwise we cannot do much to solve the problem.

Please post your license key (without sig) in the future.

Thank you.

jrdepriest

2004-02-04 18:11:15

I have created the self-signed key and tried the connection both with and without it and it fails both times.

I do not have ownership of the system I am connecting to. I will inquire about read access to troubleshoot this problem.

mb

2004-02-23 17:06:20

Hello ...

Try latest developer build.
https://www.smartftp.com/download

jrdepriest

2004-02-23 17:23:02

That might have worked.

I was able to connect without an error.

I uploaded a file, but was not able to see it after uploading it.

I am trying to verify the level of permissions the ID I have has on the 'test' directory I am connecting to.

This may be normal behaviour.

Thank you, regardless.

I'll post an update when I have any answers.

jrdepriest

2004-02-23 17:51:51