Problem Accessing FTP Server


We have problems using SmartFTP to access a FTP Server. With other tools it works very well.

The complete problem description is available on:

We just purchased SmartFTP licenses and our Customer Support Engineers (that have to use this tool very frequently) are really struggling with this issue.

Please help us!

Kind regards,
Rik Habex

try to update the the latest build. and try again and see if solve the problem.
nice explanition of the problem.
you think you can attech some raw listing if posible?

thanks in advance.


I upgraded to the latest build (1.0.973) and it's still the same problem. I think the LIST export that my FTP server sends is a little bit different then the LIST export that other FTP servers are sending (the folders are moved some characters to the right). SmartFTP then picks up the foldernames as "________xxxxx", so with a few spaces in front of the foldername. The FTP server is maybe a little bit old-fashioned, but other FTP tools do not have any problems at all with this...

Thanks for your quick reply already! :wink:


This is a raw list:

220 FUSION FTP server ready.
331 User name okay, need password.
PASS (hidden)
230 User logged in, proceed.
215 MD110 BC10 system type.
REST 100
502 Command not implemented.
200 Command okay.
REST 100
502 Command not implemented.
257 "/" is current directory.
200 Command okay.
PORT 10,12,21,235,7,247
200 Command okay.
Opening data connection IP: PORT: 2039.
150 LIST
612 bytes received successfully. (612 B/s) (00:00:01).
226 Closing data connection.
521 "/ USR1" is not a directory
200 Command okay.

Hello Rik

Excellent bug report :-)

The first step is to upgrade to the latest developer build:
- Install

We need the raw directory listing of a few directories to fix the problem.
- Connect to FTP server
- Right-click on a folder in the tree view
Select "Show Raw Directory" listing from the context menu
- Do the same for some other folders

Send all raw directory listings to bugreport aaatttt smartftp dot com

The problem will be fixed within 1-2 working days as soon as we have the listings.

Thank you.

Hi All,

I installed SFTPDev.exe succesfully.
I created 3 rawlistings (had to use manual commands for that as I could not change directories, but it's OK)
I sent everything in a ZIP file to bugreport (at) smartftp (dot) com.

The rawlistings are also available via:

We currently stopped the deployment of SmartFTP towards our client PC's. As soon as you have an updated version ready let us know and we will test it immediately...

Thanks for this great support!


New build sent to Rick in personal email.

I downloaded the new build this morning, and the problem is still the same? I checked the version and it's :

+- System -----------------------------

Microsoft Windows 2000 Professional
Service Pack 3 (Build 2195)

CPU Speed : 1132 MHz
Total Memory : 261040 KB
Free Memory : 89440 KB

+- SmartFTP ---------------------------

Version : 1.0.974.16
Time Stamp : 2003-03-16 17:55:30

+- Application DLL --------------------

Controls.dll : 1.6.974.16
FTPAPI.dll : 2.0.974.16
Language.dll : 1.0.974.16
ResEng.dll : 1.3.974.16

+- System DLL -------------------------

shell32.dll : 5.00.3502.5436
shlwapi.dll : 6.00.2800.1106
comctl32.dll : 5.81
riched20.dll :
schannel.dll : 5.00.2195.5284

+- Internet Explorer ------------------

Version : 6.0.2800.1106

+- Winsock ----------------------------

Winsock : 2.2

Is something not correctly upgraded?

Cheers and thanks!

The user reported the problem has been fixed with the latest "private" build.