Remote Edit Not Detecting Saves

Starting a new thread dedicated to this topic, as I know others have the same issue:


The bug is extremely simple:

When using remote edit to edit files in Dreamweaver, sometimes when you have made changes and hit save, the Scheduler does not pick it up and auto-run. You have to re-save it again for it to happen.
It also happens often when you highlight say 5 files to remote edit at the same time, and then you are saving. It doesn't pick up some of the saves.

Unable to reproduce. Please see the other thread for the information (reproducible case) we require to fix the problem.

I'm having the same issue by the sounds of it.

When i right click a file on the server and choose edit to remote edit the file it opens as normal in dreamweaver. When clicking save in dreamweaver it doesn't always pick up the save and upload the file to the server. Sometimes it will upload, sometimes it wont and have to save again (sometimes several times) to get smartftp to upload to the server.

Also if I have several files open for remote edit on some occasions when I click save i see one of the other open files being uploaded in the transfer queue.

System info is below

+- System -----------------------------
Microsoft Windows 7 Home Premium Edition
Service Pack 1 (Build 7601)

CPU Speed : 2094 MHz
Total Memory : 4063 MB
Free Memory : 1351 MB

+- SmartFTP ---------------------------
Version : 4.0.1216.0
Time Stamp : 2011-09-25 21:43:10
Platform : x64
Id : 400094656
Maintenance : 2012-08-24
Days in use : 600

+- Language ---------------------------

+- Internet Explorer ------------------
Version : 9.0.8112.16421

I just saw today, SmartFTP when you have 2 files open in dreamweaver on remote edit. And you save one a few times, then go to the other and hit save, it actually tried saving the wrong one again.

Did you ever have the chance to reproduce this with another editor? e.g. notepad?

I have not tried with other editors because Dreamweaver has always been used with SmartFTP for the past years and this only started happening about 2 versions ago.
I've also seen where I have two files open for remote editing, and save 1, it uploads the other.

I think I may have steps to reproduce this error:

Highlight multiple files on ftp and right click remote edit (with Dreamweaver)

Edit one.... save it.
Then switch to a 2nd file, and save that one.
Repeat with other files if it doesn't happen then, but it will upload the 1st/wrong file at some point (happens often)

I have found one issue: Files were uploaded right when the monitor started without them being modified. Maybe this is what you are seeing as well?

That happens too, but it's not the problem described.

I cannot reproduce the problem you have previously described. Can you try it with notepad?

I just tested in Notepad and it doesn't happen but it was a very short trial period.

What doesn't make sense is - I have switched PCs and switched Dreamweaver versions all fine, it is only since the last few releases of SmartFTP that the issue has happened. I run Dreamweaver CS5.5. I wonder if the poster above uses a different version?

The file monitor has been rewritten so that might be a possible reason.

I Use Dreamweaver CS3, as the poster above mentions it has only started occurring in the latest two versons of smartftp, previously it worked flawlessly.

Any fixes on this? Just opened a file up for Remote Editing this morning........ edited it, it saved. Closed the file. Went back to open it again for remote editing but this time when I hit save the scheduler did not run.

We are still waiting for your instructions on how to reproduce the problem. Did you try it with notepad? There won't be a fix for something we cannot reproduce.

See my posts - they are all examples. Here's another one: open two files on Remote Edit. One will auto reupload because of a bug, made a tiny edit and save that file, it will re-upload the opposite file.

No more updates? I'm suprised there aren't dozens of people experiencing this issue. Almost every webmaster who uses SmartFTP would use Remote Edit with Dreamweaver - and it would not be saving the files properly.

Seriously this happens constantly to everyone using Dreamweaver (must be the most popular web editor in the world after Notepad) with SmartFTP. You acknowledged it was because of the editor rewrite.

Do you have DW to test it with? It honestly is a huge problem and any company who uses the combo will have to switch FTP software.

Notch up another user experiencing this problem with Dreamweaver + SmartFTP. Have been using Dreamweaver + SmartFTP's remote file editing on Windows Vista since late last year with no problems. Clean installed Windows 7 with Dreamweaver CS5 and the latest version of SmartFTP (4.0.1217.0), and now SmartFTP fails to save remotely edited files on a regular basis.

The problem does not seem reproducible using Notepad + SmartFTP, though I have only run a cursory test.

Is there some sort of debug logger that can be activated in SmartFTP to gain a better insight into how this error is occurring?

Does it work with any other application that does the same as SmartFTP?

Comprehensive remote edit support is the primary reason we use SmartFTP here rather than another FTP client. I haven't tried remote editing with other FTP clients + Dreamweaver, as typically file association is too difficult to set up in other clients.

On another note, I had a go at trying to dump out some file handle information using Process Monitor however didn't get far as I use SmartFTP at work. One could probably use this with a filter to pull out information on 1) tcp connections 2) child processes and 3) file handles from this and filter them by the top-level process (smartftp, notepad, dreamweaver), then open, edit and save a set of remote files using notepad, then dreamweaver, and compare how SmartFTP does it for each. Maybe someone with more time to troubleshoot than I have

Good news everyone. The new build of SmartFTP (available now) includes a workaround which should take care of the issue.