Upload keeps restarting


I'm having a problem where i'm trying to upload a file to my FTP server hosted via my Router.
The size of the file does not matter as i have tried uploading a 28KB Font file and it too keeps restarting over and over.

I have included the log of an individual file where i had set max retries to zero to avoid endless restarts.

[16:29:13] Operation Begin

[16:29:13] Resolving host name ""

[16:29:13] Connecting to Port: 21

[16:29:13] Connected to

[16:29:13] 220 Welcome to Shadowblade's FTP service

[16:29:13] USER MediaAdmin

[16:29:13] 331 Please specify the password.

[16:29:13] PASS (hidden)

[16:29:13] 230 Login successful.

[16:29:13] SYST

[16:29:13] 215 UNIX Type: L8

[16:29:13] Detected Server Type: UNIX

[16:29:13] RTT: 0.770 ms

[16:29:13] FEAT

[16:29:13] 211-Features:

[16:29:13]  EPRT

[16:29:13]  EPSV

[16:29:13]  MDTM

[16:29:13]  PASV

[16:29:13]  REST STREAM

[16:29:13]  SIZE

[16:29:13]  TVFS

[16:29:13] 211 End

[16:29:13] PWD

[16:29:13] 257 "/"

[16:29:13] CWD /Programs/Video/Media

[16:29:13] 250 Directory successfully changed.

[16:29:13] PWD

[16:29:13] 257 "/Programs/Video/Media"

[16:29:13] Remote file exist check: "TransitionFX.zip".

[16:29:13] TYPE I

[16:29:13] 200 Switching to Binary mode.

[16:29:13] SIZE TransitionFX.zip

[16:29:13] 550 Could not get file size.

[16:29:13] File exist check failed. File not found or permission denied.

[16:29:13] PASV

[16:29:13] 227 Entering Passive Mode (192,168,1,1,253,235)

[16:29:13] Opening data connection to Port: 65003

[16:29:13] STOR TransitionFX.zip

[16:29:13] 150 Ok to send data.

[16:29:23] 60445357 bytes transferred. (6,03 MB/s) (00:00:09)

[16:29:23] 226 File receive OK.

[16:29:23] Setting properties (Date modified) of "/Programs/Video/Media/TransitionFX.zip"

[16:29:23] MDTM 20110907100316 TransitionFX.zip

[16:29:23] 550 Could not set file modification time.

[16:29:23] SITE UTIME TransitionFX.zip 20110907100316 20110907100316 20110907100316 UTC

[16:29:23] 500 Unknown SITE command.

[16:29:23] SITE UTIME 20110907100316 TransitionFX.zip

[16:29:23] 500 Unknown SITE command.

[16:29:23] SIZE TransitionFX.zip

[16:29:23] 213 120890714

[16:29:23] Source File Size=60445357, Destination File Size=120890714

[16:29:23] File size mismatch.

[16:29:23] Transfer failed.

[16:29:23] Operation End

[16:29:23] Max retry (0 of 0) reached.

While sitting here writing this i'm also doing some testing and it also seems like SmartFTP is showing the wrong filesize and downloading more than what is actually there.

Just for fun i tried uploading the zip file mentioned in the log above by using Microsoft Explorer.
The file uploaded successfully and i then tried downloading it to another directory to make sure that i had gotten everything both up and down.
I then opened SmartFTP to check the filesize. The correct filesize as displayed both in MS Explorer and in SmartFTPs local browser is 59.029 KB but SmartFTPs remote browser displays the size as 118.057 KB
Downloading the file through SmartFTP also yields a file on the disk with a size of 118.057 KB
When trying to unzip the file using winrar and i get a message saying that the archive is corrupt.
Downloading the same file using MS Explorer and i have no problem unzipping the file.
I have never had such a problem with zip/rar files and SmartFTP before.

BTW. when looking at the file in the queue while it is being uploaded the queue correctly displays the filesize as 57,6 MB

Any help is appreciated

ps. Sorry for ending up with two problems in the same thread.

It's a server bug. The server returns the wrong size in the SIZE reply. The workaround in SmartFTP is to enable the "Skip Post Transfer" option in the Favorite Properties, in the Transfer dialog.

So i can't really use SmartFTP until my routers firmware is fixed.

The workaround fixed the problem with endless upload retrys but the filesize is still wrong when uploading and downloading with SmartFTP (or any other 3rd party FTP client)

This has nothing to do with SmartFTP but is solely a problem with your router.