SFTP Failed to create session keys.


I am getting the following from SmartFTP Pro client on Windows 2003 to Solaris 10 server.
FTP over SSH.
I am able to connect with Filezilla using same credentials.
Please advise.

[13:30:27] Connection attempt 2...
[13:30:27] Resolving host name "batman"
[13:30:27] Connecting to Port: 22
[13:30:27] SSH-2.0-Sun_SSH_1.1.3
[13:30:27] Starting SSH session. Remote Id: "SSH-2.0-Sun_SSH_1.1.3"
[13:30:27] SSH protocol version reply. Client Id: SSH-2.0-SmartFTP
[13:30:27] Key Exchange Algorithm: diffie-hellman-group-exchange-sha1
[13:30:28] Server "ssh-rsa" host key fingerprint: 39:AE:CB:B2:4B:B4:FA:85:47:DC:95:DE:32:19:ED:D5
[13:30:28] Failed to create session keys.
[13:30:28] Client closed the connection.
[13:30:28] Connect failed. Error=0x80004005

[13:30:28] Waiting to retry (30s)...
[13:30:28] Socket Exception. Reason=0


Thanks for the suggestion. I've tried this hotfix but it didn't resolve the issue.

Out of interest, this issue only seems to affect installs on Server 2003.

Do you have any other ideas?


We will provide a new version within the next few days.

We have confirmed the hotfix is installed and updated the SmartFTP client to 4.0.1210 but still not working.
Please advise.


This has resolved the issue - many thanks.