Scheduler fails to upload files - Transfer Failed - Possible Bug


Issue with SmartFTP Scheduler using versions 4.0.1207.0 beta and non-beta 32bit versions (tried both).
>>> I am able to upload / download files directly from multiple servers using the same Favorite file / settings. <<<

I have deleted all favorites / recreated and insured all settings are default as well as having tried both PORT and PASV connections. I have also tried running this scheduled job with it uploading to HostGator, GoDaddy, and our own business servers (necessary port ranges for Active and Passive are open). All produce the same error.

While the favorite settings work perfectly for uploading files using the transfer queue - when using this favorite as part of a "Schedule" - the following occurs:

New file is added to C:\test. SmartFTP sees this new file and pushes to Transfer queue.
File shows up in transfer queue and then immediate goes to "retry at" with the following log entry:

[20:06:36] Initializing. Transfer Queue v4.0.1207.0.
[20:06:36] Operation Begin
[20:06:36] Resolving source path.
[20:06:36] Remote file exist check: "FTP".
[20:06:36] MLST FTP
[20:06:37] 250- Listing FTP
[20:06:37] size=0;modify=20110728030038;create=20110728023908;perm=cmpledf;type=dir; FTP
[20:06:37] 250 End
[20:06:37] Source File: Size=0, Date Modified=2011-07-28T03:06:35
[20:06:37] Destination File: Size=Unknown, Date Modified=2011-07-28T03:00:38
[20:06:37] RecentTime=2011-07-28T03:06:37
[20:06:37] No rule matched. Default Action="Overwrite".
[20:06:37] Transfer failed.
[20:06:37] Operation End

Scheduled Job Settings:
Trigger: Monitor folder C:\test
Action: Queue Item and add idem to head of transfer queue. Nothing else checked
Transfer Queue Item Properties = Synch: One way. Operation: Copy.
Source: Local C:\test
Destination: /FTP/ --> Have verified this is correct path per server log entry: 257 "/FTP" is the current directory (error is different when path is wrong, "cannot retrieve MLST" so path is not the issue I believe)
Transfer Type: Auto. File Exist Action = Rules (which are all default, if nothing matched = overwrite).

See the following log file of a simple upload using the interface (file uploads successfully, on all 3 hosts),

[20:08:39] SmartFTP v4.0.1207.0
[20:08:39] Resolving host name ""
[20:08:39] Connecting to Port: 21
[20:08:39] Connected to
[20:08:39] 220-Cerberus FTP Server - Professional Edition
[20:08:39] 220-This is the LICENSED professional edition and may be used for business
[20:08:39] 220-Welcome to Cerberus FTP Server
[20:08:39] 220 Created by Cerberus, LLC
[20:08:39] USER brad
[20:08:39] 331 User hidden, password please
[20:08:39] PASS (hidden)
[20:08:39] 230 Password Ok, User logged in - This is an LICENSED copy of Cerberus FTP Server Professional edition
[20:08:39] SYST
[20:08:39] 215 UNIX Type: L8
[20:08:39] Detected Server Type: UNIX
[20:08:39] RTT: 70.366 ms
[20:08:39] FEAT
[20:08:39] 211- Additional features supported include:
[20:08:39] MDTM
[20:08:39] MFCT
[20:08:39] MFMT
[20:08:39] SIZE
[20:08:39] REST STREAM
[20:08:39] AUTH TLS
[20:08:39] AUTH SSL
[20:08:39] PBSZ
[20:08:39] EPRT
[20:08:39] EPSV
[20:08:39] XCRC
[20:08:39] XSHA1
[20:08:39] XSHA256
[20:08:39] XSHA512
[20:08:39] XMD5
[20:08:39] PROT
[20:08:39] LANG EN*
[20:08:39] SITE PSWD
[20:08:39] SITE ZONE
[20:08:39] SITE UTIME
[20:08:39] MLST Type*;Size*;Modify*;Create*;
[20:08:39] CLNT
[20:08:39] CSID
[20:08:39] RMDA
[20:08:39] UTF8
[20:08:39] 211 End
[20:08:39] CSID Name=SmartFTP;Version=4.0.1207.0;
[20:08:39] 200 Name=Cerberus FTP Server; Version=; CaseSensitive=0;
[20:08:39] OPTS UTF8 ON
[20:08:40] 220 UTF8 support on
[20:08:40] PWD
[20:08:40] 257 "/" is the current directory
[20:08:40] TYPE A
[20:08:40] 200 Type ASCII
[20:08:40] PASV
[20:08:40] 227 Entering Passive Mode (98,200,224,200,43,58)
[20:08:40] Opening data connection to Port: 11066
[20:08:40] MLSD
[20:08:40] 79 bytes transferred. (1012 bytes/s) (78 ms)
[20:08:40] 150 Opening data connection
[20:08:40] 226 Transfer complete
[20:08:46] CWD /FTP
[20:08:46] 250 Change directory ok
[20:08:46] PWD
[20:08:46] 257 "/FTP" is the current directory
[20:08:46] PASV
[20:08:46] 227 Entering Passive Mode (98,200,224,200,43,59)
[20:08:46] Opening data connection to Port: 11067
[20:08:46] MLSD
[20:08:46] 157 bytes transferred. (1.64 KB/s) (93 ms)
[20:08:46] 150 Opening data connection
[20:08:46] 226 Transfer complete
[20:08:56] MLST this-is-just-a-test-file.avi
[20:08:56] 550 MLST command failed
[20:08:57] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.
[20:08:58] MLST this-is-just-a-test-file.avi
[20:08:58] 250- Listing this-is-just-a-test-file.avi
[20:08:58] size=24972;modify=20110727233147;create=20110728030953;perm=awrdf;type=file; this-is-just-a-test-file.avi
[20:08:58] 250 End

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2327 MHz
Total Memory : 2020 MB
Free Memory : 1200 MB

+- SmartFTP ---------------------------
Version : 4.0.1207.0
Time Stamp : 2011-07-18 00:44:56
Platform : x86
Id : hidden
Maintenance : 2011-07-28
Days in use : 109

+- Language ---------------------------

+- Internet Explorer ------------------
Version : 8.0.6001.18702

--Warm regards,
Brian Spaulding
System Administrator

I'm unable to reproduce the problem. Did you a schedule a folder? To verify this, go to the Schedule item properties. Then go to the actions, then to the queue properties, then to the queue item properties and ensure that the type is set to folder.

Yes indeed - I have it set to "Monitor folder = test". The program recognizes the changes to the folder so its not an issue with the actual Trigger - the problem occurs when it attempts to process the "queue" which is set to Run.

Thanks for attempting to replicate. I have replicated on 3 separate networks/systems/routers/ISPs (using remote desktop) and all do the same thing (have tried multiple FTP servers from each location). Either I have something setup wrong and do not understand how it works (I don't believe this to be the case *grin*) or there is a problem with settings/bug.

When trying to copy the new files to another LOCAL directory using SmartFTP, I get this error (trigger is set to monitor Folder):
[13:24:05] Operation Begin
[13:24:05] Source File: Size=4096, Date Modified=2011-07-28T18:21:14
[13:24:05] Destination File: Size=0, Date Modified=2011-07-28T15:53:50
[13:24:05] RecentTime=2011-07-28T18:24:05
[13:24:05] Rule "IF Destination Time=Older AND Size=Smaller AND Transfer=No Matter THEN Overwrite" matched. Action="Overwrite".
[13:24:05] Failed to set file time of "C:\test1". Error=0x80070005.
[13:24:05] Transfer failed.
[13:24:05] Operation End

I was referring to the transfer queue item properties in the actions tab and not to the monitor settings in the triggers. Please verify that you are using a folder and not a file.

Transfer queue item properties (What shows when you right click the item in the transfer queue and click properties):
Type = File (doesn't allow me to change both from the transfer queue or the Event Item Properties)
Operation = Copy
Souce = Local C:\test
Desintation = Some favorite that usually works and the correct path.

I can make some screenshots if you like or provide you FTP creds? Ive been waiting for this feature for a long long time, see my old posts

You need to drag&drop a folder and not a file. Then the type changes to folder and it will work as exepected.

Awesome! Thank you so much - this works! I was creating the entire monitoring / scheduling job manually (lol, it lets you...) and that was the problem. Thank you for your patience and responses and helping me get this working. This is an awesome feature for surveillance servers that have lots of new video files being added every minute as well as just personal website updates, etc. Im sure you are well aware of all it uses Thanks alot!