Unable To Download or Upload After Upgrade To Build 4.0.1176.0

After the upgrade to the latest build 4.0.1176.0, I'm now unable to upload or download any files. They don't even get added to the Transfer Queue and nothing appears in the log. Tried re-installing twice, and had exactly the same problem. Tried stopping and re-starting the queue - same problem. I've been using SmartFTP for a long time and never had a problem before after previous upgrades. I urgently need to upload files to a site.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 1994 MHz
Total Memory : 2037 MB
Free Memory : 1275 MB

+- SmartFTP ---------------------------
Version : 4.0.1176.0
Time Stamp : 2011-03-27 23:25:07
Platform : x86
Id : 400044813
Maintenance : 2012-04-23
Days in use : 936

+- Language ---------------------------

+- Internet Explorer ------------------
Version : 7.0.5730.13

+- Winsock ----------------------------
Winsock : 2.2

Did you restart your computer?

Yes I've re-started several times, and still the same problem.

If you haven't done so yet:
Try to uninstall SmartFTP
Then install the newest version again

Also if you have a antivirus / software firewall product installed, temporary disable/uninstall it and try again.