SFTP fails to connect

Basically, I can connect to other servers via SFTP, but this one for some reason doesn't work. I can connect to the server using Putty and the exact same login information, but for some reason SmartFTP decides to close the connection right after it's established. Here's the log of what's happening:
[19:40:40] SmartFTP v4.0.1145.0

[19:40:40] Resolving host name "xxxx"

[19:40:40] Connecting to xxx.xxx.xxx.xxx Port: 22

[19:40:40] SSH-1.99-OpenSSH_5.1p1 Debian-5

[19:40:40] Starting SSH session. Remote Id: "SSH-1.99-OpenSSH_5.1p1 Debian-5"

[19:40:40] SSH protocol version reply. Client Id: SSH-2.0-SmartFTP

[19:40:41] Key Exchange Algorithm: diffie-hellman-group-exchange-sha1

[19:40:42] Key exchange completed.

[19:40:42] Host Key Algorithm: ssh-rsa

[19:40:42] Client to Server Encryption: aes128-cbc

[19:40:42] Server to Client Encryption: aes128-cbc

[19:40:42] Session MAC: hmac-sha1

[19:40:42] Client to Server Compression: zlib

[19:40:42] Server to Client Compression: zlib

[19:40:42] Requesting service "ssh-userauth".

[19:40:42] RTT: 139.491 ms

[19:40:42] Authentication request. Method: none

[19:40:42] Server supported authentications: publickey,password,keyboard-interactive

[19:40:42] Authentication request. Method: password

[19:40:43] User authentication successful.

[19:40:43] SSH session established.

[19:40:43] Connected to xxxx.

[19:40:43] Detected Server Software: OpenSSH

[19:40:43] Opening channel 0.

[19:40:43] Channel successfully opened (Local=0, Remote=0).

[19:40:43] SSH channel closed by client.

[19:40:43] Disconnecting.

[19:40:43] Client closed the connection.

[19:40:43] Connect failed. Waiting to retry (30s)...
After that it just keeps trying to connect, repeating what's up above (except the Local Channel increases every time - Remote stays at 0).

Here's my System Information taken from SmartFTP:
+- System -----------------------------

Microsoft Windows 7 Ultimate Edition 

 (Build 7600)

CPU Speed           : 3013 MHz

Total Memory        : 2047 MB

Free Memory         : 1827 MB

+- SmartFTP ---------------------------

Version             : 4.0.1145.0

Time Stamp          : 2010-10-28 00:28:15

Platform            : x86

Id                  : 400075099

Maintenance         : 2010-10-29

Days in use         : 25

+- Language ---------------------------


+- Internet Explorer ------------------

Version             : 8.0.7600.16385

+- Winsock ----------------------------

Winsock             : 2.2

I've asked others to connect via SFTP to the server, and they got in just fine. I'll try out using or something else to see if I can connect using them, and I'll report back with my findings.

It turned out that the sftp subsystem is not enabled on this particular server. To enable the sftp subsystem on the server edit the /etc/ssh/sshd_config, then enable/add the following line (or similar):
Subsystem sftp /usr/lib/openssh/sftp-server

The next build of SmartFTP comes with a new fall-back mechanism for servers on which the sftp subsytem is not enabled. However it is recommended to enable the sftp subsystem on the server.