Remote Browser Permissions

jfm

2010-05-21 09:22:58

Just installed the latest version as shown

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 3391 MHz
Total Memory : 2047 MB
Free Memory : 2047 MB

+- SmartFTP ---------------------------
Version : 4.0.1115.0
Time Stamp : 2010-05-21 00:07:22
Platform : x86

and the 'Unix Mode' permissions are displayed incorrectly. For example in the raw listing permissions are shown as -rw-rw-rw- which is correct, while in the remote browser they are shown as ---x-wxrw-.

Regards
John Martin

mb

2010-05-21 11:53:08

I cannot reproduce it here. Maybe you still had the old data in the cache?

Regards,
Mat

jfm

2010-05-21 13:00:15

Do a refresh, still looks the same. Is there somewhere I can download the previous version.

mb

2010-05-21 13:25:19

Can you send the log from the remote browser?

jfm

2010-05-21 13:32:21

Sure, how do I get to the log and where do you want me to send it

Is this what you want

[23:46:04] SmartFTP v4.0.1115.0
[23:46:04] Resolving host name "yoda"
[23:46:04] Connecting to 192.168.1.109 Port: 21
[23:46:04] Connected to yoda.
[23:46:04] 220 NASFTPD Turbo station 2.x 1.3.1rc2 Server (ProFTPD) [192.168.1.109]
[23:46:04] USER admin
[23:46:04] 331 Password required for admin
[23:46:04] PASS (hidden)
[23:46:05] 230 User admin logged in
[23:46:05] SYST
[23:46:05] 215 UNIX Type: L8
[23:46:05] Detected Server Type: UNIX
[23:46:05] RTT: 119.669 ms
[23:46:05] FEAT
[23:46:05] 211-Features:
[23:46:05] LANG en
[23:46:05] MDTM
[23:46:05] UTF8
[23:46:05] REST STREAM
[23:46:05] SIZE
[23:46:05] 211 End
[23:46:05] OPTS UTF8 ON
[23:46:05] 200 UTF8 set to on
[23:46:05] Detected Server Software: ProFTPD
[23:46:05] PWD
[23:46:05] 257 "/" is the current directory
[23:46:05] CWD /Qphoto/Camera
[23:46:06] 250 CWD command successful
[23:46:06] PWD
[23:46:06] 257 "/Qphoto/Camera" is the current directory
[23:46:06] TYPE A
[23:46:06] 200 Type set to A
[23:46:06] PASV
[23:46:06] 227 Entering Passive Mode (192,168,1,109,220,88).
[23:46:06] Opening data connection to 192.168.1.109 Port: 56408
[23:46:06] LIST -aL
[23:46:06] 150 Opening ASCII mode data connection for file list
[23:46:06] 1458 bytes transferred. (10.1 KB/s) (140 ms)
[23:46:06] 226 Transfer complete

This is the raw listing which has correct permissions

drwxrwxrwx 14 admin administrators 4096 Jan 1 19:42 .
drwxrwxrwx 5 admin administrators 4096 Jun 18 2009 ..
drwxrwxrwx 4 admin administrators 4096 Dec 30 2008 .@__thumb
-rw-rw-rw- 1 admin administrators 23 Sep 30 2008 .hightlight
drwxrwxrwx 3 admin administrators 8192 Dec 30 2008 20060822
drwxrwxrwx 3 admin administrators 12288 Dec 30 2008 20061219
drwxrwxrwx 3 admin administrators 4096 Dec 30 2008 20070425
drwxrwxrwx 3 admin administrators 4096 Dec 30 2008 20071209
drwxrwxrwx 3 admin administrators 4096 Dec 30 2008 20080428
drwxrwxrwx 3 admin administrators 4096 Dec 30 2008 20080816
-rw-rw-rw- 1 admin administrators 2015171 Aug 20 2008 2008_Auskick_Pres_1.JPG
-rw-rw-rw- 1 admin administrators 2055376 Aug 20 2008 2008_Auskick_Pres_2.JPG
drwxrwxrwx 3 admin administrators 4096 Jan 19 12:06 20090108
drwxrwxrwx 3 admin administrators 4096 Jan 19 12:06 20090316
drwxrwxrwx 3 admin administrators 4096 Jan 19 12:06 20090320
drwxrwxrwx 3 admin administrators 4096 Jan 19 12:06 20091231
drwxrwxrwx 3 admin administrators 4096 Jan 19 12:06 20100101
-rw-rw-rw- 1 admin administrators 638285 Aug 20 2008 Boots.JPG
-rw-rw-rw- 1 admin administrators 2622420 Aug 20 2008 JakeKingsVisit.JPG
-rw-rw-rw- 1 admin administrators 355102 Aug 20 2008 Sydney.JPG
-rw-rw-rw- 1 admin administrators 189952 Aug 20 2008 ehthumbs.db

All the directories in the raw listing are drwxrwxrwx on the remote browser they are all d--xrwxrwx

All seemed fine in version 1113

Let me know if you need anything else
john...

mb

2010-05-21 13:46:58

Try the following first:
1. Uninstall SmartFTP
2. Then install the latest version again

Maybe some files have not been updated correctly. You may need to reboot between 1 and 2.

mb

2010-05-21 14:57:38

Found the problem. The compiler used an old file. it will be fixed in the next build.

jfm

2010-05-21 22:04:49

Good that you found it.

Just tried the un-intall the re-install and came back to report that it didn't make a difference and I see that you have fixed it.

Thanks
john...

mb

2010-05-22 20:48:38

Please try it with the latest version:
https://www.smartftp.com/download

jfm

2010-05-23 00:36:17

Thanks, back to normal with 1116.

john...