Automate FTP process to remote server

shantha05

2010-04-15 07:05:35

Hi

We are trying to set automate FTP process to watch a folder and transfer the files within the folder to a remote server.

We implemented the transfer queue and made that to monitor the folder. We have also made sure that the connection is set alive by sending NOOP command to the remote server every 30 secs.

When we put the files in the source folder and I was checking via windows explorer whether it gets moved to the remote folder without opening the SMARTFTP application. But it didn't transfer. As soon as I opened the SMARTFTP application the connection was established and file transfer happened automatically.

How can make SMARTFTP to establish the connection automatically and transfer files in the background without opening the SMARTFTP application.

I have already implemented a task in the task scheduler as indicated https://www.smartftp.com/support/kb/how- ... f2624.html to run SMARTFTP as a service. I have also made sure that the service is running successfully but the transfer of files doesn't happen until I open the SMARTFTP application.

Am I missing out any setting or do I need to do any configuration to do this?
Thanks
Shantha

mb

2010-04-15 10:11:27

Enable debug logging:
https://www.smartftp.com/support/kb/how- ... f2613.html

In the generated logs you might see where SmartFTP is stuck.

shantha05

2010-04-15 10:19:36

Hi

Can you just confirm me that if I run smartftp as a service it will invoke the transfer queue (watching a folder) without the need of having the SMARTFTP client application opened?

Thanks
Shantha05

mb

2010-04-15 10:40:18

When you run SmartFTP as a service, the SmartFTP.exe process/application will get started in the background. It means you don't have to login manually and start SmartFTP.

shantha05

2010-04-15 10:49:01

How does it know which FTP connection to open?

Thanks
Shantha

mb

2010-04-15 10:54:09

It uses the Transfer Queue.xml file that is saved in the accounts application data folder.

shantha05

2010-04-15 11:01:54

I enabled logging via the SMARTFTP Menu and closed the application.

I placed a text file in the source location for Transfer queue to pick up.

The file hasn't been transferred and log file hasn't been created.

Do I need really make the registry change to enable logging still?

Shantha

mb

2010-04-15 11:09:55

Yes.

shantha05

2010-04-15 11:40:51

Hi

I tried enabling the log and it added the following entry

Log Level - REG_DWORD - ffffffff

I cannot see any log entries created. Also I have added this entry on an 64 bit OS and it says DWORD 32 bit value.

DO I need to add that as QWORD 64-bit instead?

Thanks
Shantha

mb

2010-04-15 11:47:13

No DWORD 32 is good.

shantha05

2010-04-15 11:54:10

Yeah I added the registry entry and also enabled logging via SMARTFTP application.

The log file gets created when I open the SMARTFTP application but the background task scheduler job doesn't create any log file.

Any ideas?

Shantha

mb

2010-04-15 11:57:12

Make sure the background task starts and that the user it runs under has sufficient privileges.

shantha05

2010-04-15 11:59:16

The background task shows the status - running.

What previlege it needs? I gave the same user account which I currently use to logon to execute the SMARTFTP application for the task to use.

I thought that would be ok.

Shantha

mb

2010-04-15 12:33:21

Please post the system information from the menu: Help->About "System Information" dialog.

shantha05

2010-04-15 19:05:34

+- System -----------------------------
Microsoft Windows 2008 Server Standard Edition (full installation)
Service Pack 2 (Build 6002)

CPU Speed : 2400 MHz
Total Memory : 4094 MB
Free Memory : 2969 MB

+- SmartFTP ---------------------------
Version : 4.0.1072.0
Time Stamp : 2009-11-20 20:41:14
Platform : x64
Id : xxxxxxxxxxx (changed for security purposes)
Maintenance : 2011-04-01
Days in use : 50

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 7.0.6002.18005

+- Winsock ----------------------------
Winsock : 2.2

Note: Also I am trying to use SFTP (Secure FTP)

mb

2010-04-15 20:52:36

You may want to install the latest version of SmartFTP from here:
https://www.smartftp.com/download

shantha05

2010-04-15 21:05:12

Do you think whether that would be the reason for the background task not running?

Thanks
Shantha

mb

2010-04-15 21:26:17

I don't think it is the reason but it is worth a try.

shantha05

2010-04-15 21:30:00

Ok I will try installing the latest version on my Virtual PC and test it and let you know whether it works fine.

Thanks
Shantha

shantha05

2010-04-16 01:42:55

Hi

Just to give you further update on this. We have configured the trigger in the scheduler for the task to start SMARTFTP as a service to begin task at startup.

The status shows as running. But if we put files in the local folder nothing happens.

I changed the above task to run every 5 minutes and stopped the task and started it again. Then the files were transferred.

I created couple of files again in the local folder.

The task didn't stop after it completed. The task tried to restart the exe again after 5 minutes but it threw an error saying the exe is already running but the files are still in the local folder. It will transfer if I stop and start the task.

Any ideas?

Thanks
Shantha

mb

2010-04-16 01:56:03

The task needs to be running constantly. So do not trigger it every 5 minutes.

To verify if SmartFTP.exe process is created, you can check the debug logs that you have enabled earlier.

shantha05

2010-04-16 02:04:49

Hi

I can see the log file created only for via SMARTFTP application.

I cannot see that created for the task that's running in the background.

Also I changed it to 5 minutes just for testing so that I can stop and start.

Shantha

shantha05

2010-04-16 07:21:06

Hi

Can you list the configurations I need to do to run smartFTP as a service and explain how it does the transfer without opening the application?

I have installed the trial version of SMARTFTP and configured running SMARTFTP as a service via task scheduler. I have enabled logging by making registry changes as well as enabling logging via application still I cannot see any log file or file transfer happening.

But the log file gets created if I open the SMARTFTP application. I have checked SMARTFTP.exe is appearing in task manager. Also windows firewall has got an exception for SMARTFTP.exe.

I really want to understand how the background process works. This is really urgent for us and I need the reply as early as possible.

Thanks
Shantha

mb

2010-04-16 12:27:14

You may want to try to run it under a different/separate user account. In this case you have to setup evertyhing (license key activation, transfer queue, favorites, other settings) under this account first.

shantha05

2010-04-21 09:13:29

Hi

Just to let you know that the issue has been sorted. In Windows 2008 server, exe files couldn't be executed via the task scheduler.

So I needed to create a batch script to invoke the exe and schedule it in the task scheduler.

Now SMARTFTP works fine as a background service.

I have read in other forums that even in Vista, exe files couldn't be executed.

All sorted via the batch file.

Hope this will be helpful for others too.

Thanks
Shantha