Slow file write to UNC path (from Windows Home Server to Windows 7)

Leeward

2010-03-14 08:12:35

Hello,

I encountered a strange issue.
The latest 32 bit version of SmartFTP, running on Windows Home Server (I believe it's Windows server 2003 code base), when downloading via a fast internet (Verizon FiOS), can write to the local C: drive with a stable 2.5MBytes/sec speed for hours.
However, when the download destination is set to a 64 bit Windows 7's network share \\server\share, the speed drops significantly to only 200 - 300 KBytes/sec.
The puzzling fact is, from this Windows Home Server, with xyz downloading the same file to the same network share, the speed is stable at 2.5MBytes/sec.
This made me think it's probably a SmartFTP issue.

In my case, when the download destination is a UNC name, SmartFTP would not abort an ongoing transfer (Abort has no effect) in the queue; stop the queue would not stop the ongoing transfers (even though the stop button is disabled and the start button is enabled); shutting down SmartFTP (click the X button) would not terminate the SmartFTP process (The UI does disappear, but I had to kill the process from Task Manager).
All those three problems (along with the significant slowness) won't be there if the download destination is a local drive.

Please advise.

Thanks!

mb

2010-03-14 17:45:29

Please post the system information from the menu: Help->About dialog in SmartFTP.

What is SmartFTP's cpu usage during the slow transfer? And what is the usage during the transfer to the local computer?

Regards,
mat

Leeward

2010-03-18 04:34:26

System Info


+- System -----------------------------

Microsoft Windows Server 2003 Standard Edition 

Service Pack 2 (Build 3790)



CPU Speed           : 1596 MHz

Total Memory        : 2037 MB

Free Memory         : 1452 MB



+- SmartFTP ---------------------------

Version             : 4.0.1085.0

Time Stamp          : 2010-03-18 19:36:15

Platform            : x86

Id                  : 400096762

Maintenance         : 2011-03-03

Days in use         : 0



+- Language ---------------------------

en-US



+- Internet Explorer ------------------

Version             : 8.0.6001.18702



+- Winsock ----------------------------

Winsock             : 2.2


On both cases the process' CPU usage is around 2% - 3%.


Thanks for looking into this. Please let me know if additional information is needed.

mb

2010-03-18 07:00:34

I tried to reproduce it the following way:

2 different systems (physical) on one network connected by a hardware router:
1. SmartFTP on Windows XP (similar kernel as Windows 2003) and downloading a file from FTP to a UNC path (\\vista\movies) on Windows Vista
2. SmartFTP on Windows 7 downloading a file from FTP to UNC path (\\vista\movies) on Windodws Vista
3. SmartFTP on Windows XP 64-bit (same kernel as Windows 2003 64-bit) downloading a file from FTP to UNC path (\\vista\movies) on Windows Vista

What protocol do you use?
1. FTP
2. FTPS (FTP over SSL/TLS)
3. SFTP (SFTP over SSH)

Regards,
Mat

Leeward

2010-03-18 12:56:01


...
What protocol do you use?
1. FTP
2. FTPS (FTP over SSL/TLS)
3. SFTP (SFTP over SSH)
...
2 - FTP over SSL (Explicit)

A couple of details that might be helpful:

- Both control and data connection are private (secure).
- No client certificate is used.
- Passive mode is used for data connection.
- FTP server port is not 21.
- Only 1 data connection.

mb

2010-03-18 12:58:54

Can you try with FTP (no SSL).

If you cannot login with standard FTP it should be sufficient to set the data protection for the data connection to clear (instead of private).

Leeward

2010-03-21 22:02:13

mb

2010-03-21 22:19:54

Thanks. Are you using VmWare Workstation?

Did you also test it with a FTP server running on the same phsyical machine (Windows 7 64-bit)?

Leeward

2010-03-21 23:26:04


Thanks. Are you using VmWare Workstation?

Did you also test it with a FTP server running on the same phsyical machine (Windows 7 64-bit)?
Yes, I'm using VMware Workstation 6.5.3 build-185404 (the latest in v6)

No, the FTP server is ProFTPD (1.3.2 (stable) standalone mode) running on a different physical machine (Mac OS X Snow Leopard).


I actually realized that I have another physical machine (Win7 32 bit).
If it helps (to not use any virtual machine), I can test downloading from my primary physical machine (Win 7 64 bit) to that physical machine (Win 7 32 bit) via UNC path.
Then it's about three physical machines with 1000m wired LAN.

mb

2010-03-22 00:07:12

Let me try if I can reproduce it with your kind of setup. If you have time you could try to run a Windows FTP server on the machine/OS where Vmware runs (Windows 7 64-bit). This would mean we could reduce the setup to 1 physical machine (with 1 host os and 1 guest os).

mb

2010-03-22 13:41:49

I apologize for not requesting this information earlier :-(
Can you post the log from the transfer? You can get it by double clicking the file in the transfer queue.

Thanks
Mat

mb

2010-03-31 09:47:45

Please try it with the new beta version:

32-bit
https://www.smartftp.com/download

64-bit
https://www.smartftp.com/download

Thanks.

Regards,
Mat

Leeward

2010-04-04 15:18:39


Please try it with the new beta version:

32-bit
https://www.smartftp.com/download

64-bit
https://www.smartftp.com/download

Thanks.

Regards,
Mat
Hi Mat, I tried both the 32 and 64 bit beta (1093) but unfortunately the slowness in FTPS+UNC remains. (verified FTPS+LocalDisk works fine)
In addition, the CPU usage is very high during transfer (more related to speed than to TLS/SSL) but maybe that's because of beta.
However, the stop queue button (or shutdown SmartFTP) does work correctly now.

I'm sending a screenshot and two log files to you shortly.

Thanks!

Leeward

2010-04-14 02:09:24

Hi Mat,

Just to report that I verified the new version 1097 works perfectly for the UNC path file write.
Thank you for the fix!