Time Stamps in Remote Browser

I'm accessing a remote shared internet host that runs linux and PureFTPd, managed by a large hosting company.

The time stamps on the remote files, shown in the SmartFTP remote window, are not influenced by the time zone that I set in Favorites. I've switched Favorites to many different time zones, restarting the connection and SmartFTP between, all to no avail.

I found the forum post at https://www.smartftp.com/forums/index.ph ... incorrect/ that reports a similar issue, so I'm now running SmartFTP 4.0.1078.0 (x64).

I have a relatively complex file structure that needs to be maintained there, and the time problem makes rapid updates difficult if not impossible.

My client machine Runs Windows 7 Pro x64.

uname -a on the remote host tells me
Linux box531.bluehost.com 2.6.28-10.7.intel.E1000E.BHsmp #1 SMP Thu Aug 13 21:45:18 MDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Help me, Premium Support; you're my only hope.

Here's the SmartFTP log when I connect:

[14:02:20] SmartFTP v4.0.1078.0
[14:02:20] Resolving host name "xxxxxxx.com"
[14:02:20] Connecting to Port: 21
[14:02:20] Connected to xxxxxxx.com.
[14:02:20] 220---------- Welcome to Pure-FTPd [TLS] ----------
[14:02:20] 220-You are user number 13 of 1000 allowed.
[14:02:20] 220-Local time is now 15:02. Server port: 21.
[14:02:20] 220-IPv6 connections are also welcome on this server.
[14:02:20] 220 You will be disconnected after 15 minutes of inactivity.
[14:02:20] USER xxxxxxxc
[14:02:20] 331 User xxxxxxxc OK. Password required
[14:02:20] PASS (hidden)
[14:02:20] 230-User xxxxxxxc has group access to: xxxxxxxc
[14:02:20] 230 OK. Current restricted directory is /
[14:02:20] SYST
[14:02:21] 215 UNIX Type: L8
[14:02:21] Detected Server Type: UNIX
[14:02:21] RTT: 53.707 ms
[14:02:21] FEAT
[14:02:21] 211-Extensions supported:
[14:02:21] EPRT
[14:02:21] IDLE
[14:02:21] MDTM
[14:02:21] SIZE
[14:02:21] REST STREAM
[14:02:21] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[14:02:21] MLSD
[14:02:21] ESTP
[14:02:21] PASV
[14:02:21] EPSV
[14:02:21] SPSV
[14:02:21] ESTA
[14:02:21] AUTH TLS
[14:02:21] PBSZ
[14:02:21] PROT
[14:02:21] 211 End.
[14:02:21] Detected Server Software: PureFTPd
[14:02:21] PWD
[14:02:21] 257 "/" is your current location
[14:02:21] CWD /public_html
[14:02:21] 250 OK. Current directory is /public_html
[14:02:21] PWD
[14:02:21] 257 "/public_html" is your current location
[14:02:21] TYPE A
[14:02:21] 200 TYPE is now ASCII
[14:02:21] PASV
[14:02:21] 227 Entering Passive Mode (69,89,22,140,109,212)
[14:02:21] Opening data connection to Port: 28116
[14:02:21] MLSD
[14:02:21] 150 Accepted data connection
[14:02:21] 226-Options: -a -l
[14:02:21] 226 36 matches total
[14:02:21] 4153 bytes transferred. (51.9 KB/s) (78 ms)
[14:02:52] NOOP
[14:02:52] 200 Zzz...

MLSD returns the time in UTC (or at least it should) and therefore the timezone setting is ignored (it is not used). My guess is that PureFTPd returns the wrong date/time.

I downloaded and installed the SFTPMSI.exe that you pointed me to, which is still build 4.1078.0 (you appear to have changed your reply? ok).

Still the Favorites TZ setting has no influence on the time display in the remote browser window.

When I ssh into the remote host and ls-l, the time on my target file is 16.07 (4:07pm), SmartFTP reports it as 3:07 no matter how I set the TZ.

Am I misinterpreting how this is supposed to work? SmartFTP does not adjust the times to the TZ?

Thanks for your help.

I see from your Knowledge Base that PureFTPd has some known bugs with time stamps. That may be the problem. Anyhow I'll have to come up with a work-around.

SmartFTP always displays the time adjusted to the computer (current user) timezone settings.
The timezone settings in the favorite properties are good for legacy servers that do not return the time in UTC. This is the case when the server does only support LIST and not the newer MLSD command. LIST always returns the time in the local time zone of the server, where MLSD should always return the time in UTC. Then the local server time is converted to the UTC time using the favorite item's TZ settings. And when the time is displayed in the SmartFTP remote browser it is converted from UTC to the current user's time (using the current logged in users's timezone settings).

Thank you. That should help me resolve the issue.