Filter .svn directories

KristianB

2010-01-15 16:33:33

Hi all,

if I upload files from my project, I dont want to upload my subversion .svn directories. So I have seen the option "Filters". But everything I configure in this dialog, SmartFTP don't care about it. Everytime SmartFTP upload my subversion files and directories :-(

Image

Where is the fault?

Regards, Kristian

mb

2010-01-15 22:46:56

Welche version von SmartFTP benutzt du? Bitte system information vom menu: Help->About "System Information" posten.

Danke.

KristianB

2010-01-16 01:31:18

Hi,

danke für die schnelle Antwort. Ich nutze die Version: 4.0.1072.0

mb

2010-01-16 02:22:12

Selektierst du die .svn folders auch wenn du dieses uploadest, oder selektierst du 1 folder welcher .svn folders enhaelt?

KristianB

2010-01-16 13:15:38

Letzteres: Ich selektiere Projektordner, die meine Projektdateien enthalten bzw. Unterordner enthalten. Diese Ordner enthalten versteckte .svn Ordner / Dateien. Im Windows Explorer sehe ich die .svn Ordner nicht.

Die Ordner, die ich hoch laden möchte, ziehe ich mit Drag & Drop in das SmartFTP Fenster.

mb

2010-01-16 23:03:56

Und dann wahlest du "Use Automatic Rules" im file exist dialog?

KristianB

2010-01-17 18:14:06

Der "file exists" Dialog erscheint doch nur, wenn bereits .svn Ordner auf dem Server sind, oder? Dieser Zustand sollte doch eigentlich gar nicht auftreten! Ich hab natürlich die fehlerhaft hoch geladenen .svn Ordner / Dateien sofort wieder gelöscht. Bei einem erneuten Upload wurden die .svn Ordner jedoch wieder hoch geladen.

mb

2010-01-18 06:53:07

Jo sollte nicht sein. Du kannst die file exist option von "Ask" auf "Use Automatic Rule" tun in the Favorite Properties: Transfer->File Exist settings.
Dann wierden immer die automatic rules gewaehlt und die .svn werden gefiltert.

KristianB

2010-01-18 13:51:54

Mit diesem Tipp werden die SVN Ordner ja aber trotzdem mindestens ein mal hoch geladen. Das kann ja nicht richtig sein. Ich habe Smart FTP mal auf einem anderen Rechner ausprobiert (mit den gleichen Einstellungen) und dort funktioniert es. Das ist sehr komisch. Ich installiere Smart FTP inkl. Einstellungen mal neu.

mb

2010-01-18 13:57:31

Eventuell aenderst du die settings beim falschen favorite? Zu kommst direkt in die korrekten settings indem du zum server connectest, dann ins menu: Favorites->Favorite Properties gehst.

KristianB

2010-01-25 14:23:11

Hi,

ich hab die Einstellungen immer beim richtigen Favoriten Eintrag gewählt. Auch eine Neuinstallation brauchte erst mal leider keine Abhilfe.Dann habe ich nochmal alles deinstalliert und danach den Ordner in \AppData\Roaming\SmartFTP gelöscht, sowie alle Registry Einträge von SmartFTP gelöscht. Jetzt funktioniert es. Komisch.

Vielen Dank jedenfalls für deine Hilfestellung.