could not install smftp to my windows 7

I just built a new tower and to my surprise after downloading the 64 bit smftp I got the error message "the windows installer could not be accessed"

I had to problem with the xp/32 bit software.

Any ideas or has anyone else ran into this message/error with windows 7.

(I have had no problem with loading up CoH/L4D and silent hunter4.

still no luck.. did what the link told me to do.. I double click the file and to no luck.

I deleted the folder and downloaded the 64 client for the 2nd time also with the same error message......

Try to contact the technical support at Microsoft.

Try to contact the technical support at Microsoft.

I will give them a holler Monday..then will post on what they have to say so the forums can keep microsoft's reply as a reference.

thank you for the fast reply, alfie

Did you see if you have anything related to this in the system event log?

Also you can try to run msiexec.exe with logging enabled:
msiexec.exe /i SmartFTP.msi /l*.


nothing at all towards the smt ftp.

I went and reformated the comp.. the only this that I did diff this time was NOT to have my virus scanner and spy doctor active.

all loaded great and am now up and running.

thxs mb for the posting in a quick manner... alfie