Customised Email Notifications

Sean

2009-10-09 13:18:04

I would like to add the source path to my daily email notification. I have tried following the KB https://www.smartftp.com/support/kb/emai ... f2610.html

When I add the - {Source.Path} variable to the email Subject I just receive an email that shows “- {Source.Path}” and not the actual path.

1. Please could you advise how I use these variables, some examples of the syntax.
2. The KB article mentions an email template. How can I edit this template to include the - {Source.Path} variable? I cannot see any templates under the SmartFTP install directory.

Many thanks for your help in advance.

mb

2009-10-09 15:18:16

Hello ..

Please install the latest version:
https://www.smartftp.com/download

Then go to the menu: Tools->Settings. Then to the Queue->Email dialog. There you can edit the Templates.

Regards,
Mat

Sean

2009-10-12 08:45:37

Mat

Thanks for the reply. Is this latest version supported on Windows 2000? The machine is soon to be replaced but it would be desirable to have this customised email working now.

Thanks

Sean

mb

2009-10-12 10:04:23

Hello Sean ..

Unfortunately the latest version does no longer support Windows 2000.

Regards,
Mat

Sean

2009-10-12 11:25:07

Mat

I have installed the latest version on XP and have been playing with the templates. However I cannot get it to do what I want.

I want the email to tell me that each source folder in the Transfer Queue has been processed successfully or failed. E.g.

Transfer Queue source:
d:\Tom
d:\Dick
d:\Harry

The email should state Tom, Dick & Harry have completed successfully or three emails should state either Tom, Dick or Harry has completed successfully. At the moment it sends an email for every folder, sub folder and file it processes. This would cause thousands of emails. e.g.

d:\Tom\a.doc
d:\Tom\b.doc
d:\Tom\c.doc
d:\Tom\Tom\a.doc
etc…..

Is this possible?

Thanks again.

mb

2009-10-12 18:05:55

Try the [x] group item notification. This way only one email per "group" will be sent.

Sean

2009-10-15 12:20:13

From Settings / Queue / Email / Notification I have selected “on transfer queue item group processed”.

From the transfer queue I have grouped by “Group ID”.

With these settings I do not receive any email. I can receive a test email.

From Settings / Queue / Email / Notification if I also select “on transfer queue completion”, I then receive one “transfer queue complete” email notification when both groups have completed.

Am I missing something? Do I need to make any other configuration changes to receive notifications for each group?

mb

2009-10-15 15:27:51

What version of SmartFTP are you using?

You dont need to have the queue view grouped by groupid.

How do you add the items to the transfer queue?

Regards,
Mat

Sean

2009-10-19 08:53:39

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2992 MHz
Total Memory : 1022 MB
Free Memory : 225 MB

+- SmartFTP ---------------------------
Version : 4.0.1054.0
Time Stamp : 2009-10-06 19:54:07
Platform : x86
Id : 400087674
Maintenance : 2009-10-23
Days in use : 358

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2


I don’t understand how to group items. I thought this was via the transfer queue view. Please can you explain how I group items. I want to receive an email for each root directory.

Stop the transfer queue.
Drag and drop folders from the local browser to the remote browser.
Start the transfer queue.

Thanks.

Sean

mb

2009-10-19 09:11:44

Hello

If you want to "manually" group items, add each root folder individually to the transfer queue. This way every folder gets its own group id.

Regards,
Mat

Sean

2009-10-22 08:32:18

Mat

I deleted the root folders in the transfer queue and added new folders by the drag and drop method explained previously. This generated an email for the group.

My problem now is that I cannot stop the transfer queue. When I hit stop, it stops for about a second and then starts again. I have tried opening and closing the client but no good.

How can I forcefully stop the transfer queue?

Thanks

Sean

mb

2009-10-22 10:25:59

I don't know why this doesnt work for you. Try this:
https://www.smartftp.com/support/kb/how- ... f2625.html

Regards,
Mat

Sean

2009-10-26 12:03:26

Mat

I have deleted the registry keys and stopped the transfer queue.

I added the root folders to the transfer queue and set a schedule. Again I am not receiving an email for each transfer queue group.

It appears that the notification does not work for scheduled items.

Please can you confirm that this is a bug or provide me with instructions for setting up a transfer queue schedule that will send emails for each group id.

Many thanks.

Sean

mb

2009-10-26 12:13:26

Hello Sean ..

Yes it seems it's a bug. I have fixed it already. The new version should be released soon (1-2 days).

Regards,
Mat

mb

2009-10-26 20:57:12

Please test it with the latest version:
https://www.smartftp.com/download

Thank you
Regards,
Mat

Sean

2009-10-28 14:54:53

Mat

All works.

Thanks very much for your help.

Sean