Problems with version 4.0.1048.0


I am in a fix with SmartFTP. I have been using it for years without any problems and until recently I had version 3.x. I renewed my maintenance and upgraded to version 4 only to find out, like others here on the forums that it does not work. When I say this, I am referring to the upload feature. When I go to any of my saved FTP accounts and attempt to upload a file, around 50-80kb of it goes to the server and the rest does not transfer. The transfer speed in the queue window is 0, there is no activity.

I uninstalled version 4, restarted, reinstalled, same problem.

I saw other people had the same problem and it was suggested that they downgrade to version 3.x, so I tried to find it on your site, couldn't but fortunately still had the installer for 3.0.1024.32 on my machine. I uninstalled version 4, restarted my computer, installed version 3 now to find that it will not open because of a runtime error. By this time I am already frustrated with all this install, uninstall, restart, install process. I deleted the queue.dat file in my profile, still didn't work, tried deleting other .dat files, still does not work.

Here is a screenshot of the error message:


Please can you advise what is going on and what I need to do to resolve this problem. This is a major inconvenience.

Many thanks


The bug you have seen in version 4 has been fixed now:

It was only triggered when using a transfer limit. For your troubles we have extended the maintenance of your license by 1 year for free.