External "view" program not launched

As always, please accept my apologies if this is covered elsewhere here, I could not find good search words to use for this issue :-/ Too common here in the forums.

Using version 4.0.1048.0 on XP Pro SP3 + all post hotfixes from m$ update.

Starting with one of the last few 3.x versions, up through current version, the setting for external file viewer does not launch my program any longer. Instead it opens a Windows Explorer pane onto the directory SmartFTP is installed.

I have done a copy/paste of my external file viewer entry in SmartFTP settings, into a "run" box and it launches my external viewer.

This had been working well for quite some time, until recently as noted above.

Help and info appreciated as always.

Thanks and regards,

Hello ..

I made some changes recently in the view/open code. What did you setup as the viewer in the menu: Tools->Settings "General" dialog? Can you paste the complete path to the file.

Does it work if you use notepad.exe as the viewer?


Hi Mat, thank you for fast reply as always!

(Yes yes I know I still owe you more info on the timestamp/timezone issue... I'm not as fast as you :-( )

My full path in Tools -> Settings -> General -> File Viewer is:

D:\Program Files\JGsoft\EditPadPro6\EditPadPro.exe

This line does launch EditPadPro from windows "run" box. I have not used any quote marks in the line, it is just as I have pasted it above.

So, I did try putting quote marks " " around this line in SmartFTP, and SmartFTP appears to save it. But when I exit and re-launch SmartFTP, SmartFTP has changed it to C:\WINDOWS\notepad.exe.

So now it is pointing to Notepad. I logged in and verified the setting is still pointing to notepad. I tried to use VIEW from the menu, and the Windows Explorer pane onto the SmartFTP installation directory opened just as before.


Hello appyface ..

I'm sorry but I cannot reproduce it. I have tested it on Windows XP 32-bit. Set the default viewer to notepad. Connected to our ftp server (ftp.smartftp.com), went into the SmartFTP folder, right-clicked on the History.txt and select View from the context menu. Then the queue downloads the file and opens it in notepad.exe

Please try to stop the transfer queue, then right-click on the file and select View from the context menu. Then a new item is added to the transfer queue. What is the destination path/folder of this item?


Hi Mat,

I reproduced by using server FTP://SMARTFTP.COM :-)

I navigated to folder SmartFTP then folder RFC as there are many viewable text files there.

I stopped the tranfer queue.

I then right-clicked on filename rfc959.txt and chose "View" from the shortcut menu.

Nothing was added to the transfer queue. Windows Explorer opened on the installation directory for SmartFTP as before.

This is in the log file:

[16:20:56] 200 NOOP command successful.
[16:21:02] PASV
[16:21:02] 227 Entering Passive Mode (75,126,59,170,62,145)
[16:21:02] Opening data connection to Port: 16017
[16:21:02] RETR rfc959.txt
[16:21:02] 150 Data connection accepted from; transfer starting for /SmartFTP/RFC/rfc959.txt (147316 bytes)
[16:21:02] 226-Compression : 25.22% (36.291 KBytes/143.863 KBytes).
[16:21:02] 226 File sent ok.
[16:21:02] 37162 bytes transferred. (74.9 KB/s) (484 ms)

Also, in my settings under General -> Navigation, I have the following:

Double Click Action = View
Delete = Browser
Open / View / Print = Browser

For a test I changed the last one from Browser to Queue.

The file is now added to the Queue using "view". And if I start the queue, when it finishes, windows explorer opens on the SmartFTP installation directory as before.

The "properties" on the file added to the queue show:

Operation = Copy
Source = Remote
smartftp.com - anonymous
Destination = Local

"C:\tempuser" is from my environment variable for windows user temp directory.

There is 17G free disk space on the c: drive.

Interesting to note, the 'edit' command from right-click menu puts the file into the transfer queue and when it completes opens notepad.exe on the file.


Please post the value of the following registry key:

Hi Mat,

Using regedit, the exported key is this:

Windows Registry Editor Version 5.00


On screen in regedit I can see that the value of the data item: (default)
and contains: %SystemRoot%\system32\NOTEPAD.EXE %1

I confirm the environment variable SystemRoot is correct set as C:\WINDOWS

And I confirm Notepad is located at C:\WINDOWS\system32\notepad.exe


I will try to create a debug version for you because I cannot reproduce the problem.

I will try to create a debug version for you because I cannot reproduce the problem.
No problem, just let me know when it is ready. Thanks,

I have sent you the debug version with instructions to your sneaky email.

I have sent you the debug version with instructions to your sneaky email.
LOL I will reply in my usual sneaky way then. Thanks :-)