SFTP issue; connection actively refused

avdgoot

2009-09-01 13:15:16

Dear SmartFTP support,

I've come across SFTP servers that refuse a connection with SmartFTP. When I tried "SmartFTP - FTPS" under Favourites the same response appeared (see output below).
I'm under the impression that this may be due to recent SFTP changes/enhancements. I did not try version 4.0 yet (see "SmartFTP v4.0.1047 SFTP Problems" thread).

Thank you and best regards,
Atze

Output:
[15:01:38] SmartFTP v3.0.1045.0
[15:01:38] Resolving host name "ftp.smartftp.com"
[15:01:38] Connecting to 75.126.59.170 Port: 21
[15:01:38] Connected to ftp.smartftp.com.
[15:01:38] 220 SmartFTP Server ready...
[15:01:38] AUTH TLS
[15:01:38] 234 AUTH command ok; starting SSL connection.
[15:01:38] Connected. Exchanging encryption keys...
[15:01:39] Session Cipher: 128 bit RC4
[15:01:39] TLS encrypted session established.
[15:01:39] Command channel protection set to Private.
[15:01:39] PBSZ 0
[15:01:39] 200 PBSZ=0
[15:01:39] USER anonymous
[15:01:39] 331 Password required for anonymous.
[15:01:39] PASS (hidden)
[15:01:39] 230 User anonymous logged in.
[15:01:39] SYST
[15:01:39] 215 UNIX Type: L8
[15:01:39] Detected Server Type: UNIX
[15:01:39] RTT: 135.583 ms
[15:01:39] FEAT
[15:01:39] 211-Extensions supported:
[15:01:39] AUTH TLS
[15:01:39] CCC
[15:01:39] CLNT
[15:01:39] CPSV
[15:01:39] EPRT
[15:01:39] EPSV
[15:01:39] MDTM
[15:01:39] MFCT
[15:01:39] MFMT
[15:01:39] MLST type*;size*;create;modify*;
[15:01:39] MODE Z
[15:01:39] PASV
[15:01:39] PBSZ
[15:01:39] PROT
[15:01:39] REST STREAM
[15:01:39] SBUF
[15:01:39] SIZE
[15:01:39] SSCN
[15:01:39] TVFS
[15:01:39] UTF8
[15:01:39] XCRC "filename" SP EP
[15:01:39] XMD5 "filename" SP EP
[15:01:39] XSHA1 "filename" SP EP
[15:01:39] 211 End.
[15:01:39] CLNT SmartFTP 3.0.1045.0
[15:01:39] 200 Noted.
[15:01:39] Detected Server Software: Gene6 FTP Server 3.x
[15:01:39] OPTS UTF8 ON
[15:01:40] 200 UTF8 OPTS ON
[15:01:40] OPTS MLST type;size;create;modify;
[15:01:40] 200 MLST OPTS type;size;create;modify;
[15:01:40] PWD
[15:01:40] 257 "/" is current directory.
[15:01:40] TYPE A
[15:01:40] 200 Type set to A.
[15:01:40] MODE Z
[15:01:40] 200 Mode Z ok.
[15:01:40] PROT P
[15:01:40] 200 PROT command successful.
[15:01:40] PASV
[15:01:41] 227 Entering Passive Mode (75,126,59,170,62,202)
[15:01:41] Opening data connection to 75.126.59.170 Port: 16074
[15:01:41] MLSD
[15:01:42] No connection could be made because the target machine actively refused it.

mb

2009-09-01 13:36:00

I believe that is a network problem. Go to the favorite properties: FTP->Connection->SSL/TLS and under Data Connection set the mode to Clear for both the File Transfer and List Transfer option.

avdgoot

2009-09-02 11:14:26

Ok. I've modified the settings as indicated for the "Default Favorite" (only there I could find SSL/TSL under connection). It did not change the behaviour (same in version 4.0.1048.0). Still "No connection could be made because the target machine actively refused it". Please advice.

Regards
Atze

mb

2009-09-02 12:38:54

Try active mode (PORT).