SmartFTP Not Showing Current File

How can this be?

I have a .asp file with 577 lines of code in it. I transfer this from my desktop to my ftp site.
When I right click on the file in the SmartFTP remote browser window and choose open or view or edit,
the file now has 605 lines of code in it, and the lines are jumbled up. The .asp script works
properly so I have to assume the correct file is getting transferred but SmartFTP is
showing an altered version. What could be going on here?

Here's another oddity. The properties on this file say it was created on August 30 and modified
on August 24. How can that be??

1. Install the latest version of SmartFTP:
2. Post your system information from the menu: Help->About "System Information" dialog
3. Download the file with binary mode
4. Open the file in an editor

OK, thanks for your reply. Did those things (see below) including changing the transfer mode to binary. Still not getting the real version when the file is opened from the remote browser window.

Sometime during the editing life of this file, SmartFTP put a copy in a temporary directory, as I'm sure it does whenever you open/view/openwith/edit a file. Many updates were made to the file in its native local computer location after this version was placed in the temporary directory, and the file was then transferred to the remote server and updated correctly on the server. But SmartFTP, who is monitoring the file, continues to present the old version from the temporary directory every time I open/view/edit the new version on the remote server. It thinks the version in the temporary directory is the latest version even though it is not. The properties associated with the old version in the temporary directory are the up to date properties of the new version but the content in the file is old. So apparently the version in the temporary directory is not getting updated when the file is updated even though the file is getting updated on the server.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2204 MHz
Total Memory : 2046 MB
Free Memory : 1086 MB

+- SmartFTP ---------------------------
Version : 4.0.1047.0
Time Stamp : 2009-08-31 6:02:21
Platform : x86
Id : 400082697
Maintenance : 2009-10-07
Days in use : 765

+- Language ---------------------------

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

Hello ..

Yep the process is as you described. SmartFTP only downloads the file again if it thinks that the file on the source is newer/different. It compares the last modified date of the source file, if its newer than the existing destination file the source file is transferred. In your case it seems that the file on the server is always older than the temporary file.

Can you verify if this is the case? You can get the complete transfer log by doing the following:
1. stop the transfer queue
2. right-click on the remote file you want to view/edit etc and select view
3. the item is created in the transfer queue. double click the newly created item. a log window shows
4. start the transfer queue

Now you can find the reason the file is skipped in the log.


Hello Mat,

Thanks for the quick reply. I will try the suggested experiment and agree with everything you say except I would modify your statement to be "In your case it seems to SmartFTP that the file on the server is always older than the temporary file, when in fact it is newer." The file on the server is up to date, but when you ask to view it you get this old version of the content from the temporary file. It appears to me that SmartFTP is updating the properties of the temporary file (to the ones of the new file) but not updating the content.

I "deleted" the old bad version from the temporary directory by changing its name. Now SmartFTP could no longer find the temporary version and presented the real up to date version from the server as requested. That's the good news. But now of course I could no longer demonstrate the problem to those who might think I am insane. But even better news... it's doing it on at least one other file and I can demonstrate it at will. It's a prety basic issue: ask to open/view/edit this file and it will show you something else! I'll be happy to link you in or send some screen shots if you want to see it.

Now for the suggested experiment...



Did the experiment. The log was empty, zero entries. Then, SmartFTP got re-synched somehow with all the latest versions and my ability to "demonstrate it at will" disappeared. This left me in the embarrassing position of not having a problem and not being able to demonstrate the problem I didn't have.

But now it's back again. Ask to see a file and you get to see an old version from a temp directory. I have a theory. The theory is that SmartFTP watches the version in the temp directory for changes on the assumption that the file cannot have changed unless the version in the temp directory changes.

If this is the case then I got a problem because the file is being updated by another computer (also using a licensed version of SmartFTP), and my local version is not detecting these updates. The solution would seem to simply be to disable monitoring on the local computer, but every time I do this the next time I transfer the file on the local computer it goes into "monitoring" mode.

Is this theory correct, and, if so, can you tell me how to permanently disable monitoring?


Please provide the log from the transfer queue. When you view a file the file is always processed through the transfer queue first. Therefore you should get a log from this transfer. The log would indicate whetherh the file has been skipped because SmartFTP thinks is up-to-date or if it has been transferred again.

The file monitor is only enabled if you "Edit" a file. If you just View/Open a file no file monitor is used.


The log is empty. I can send a screen shot if you like.

Please install the latest version (build 1048) if you haven't done so yet:

then stop the transfer queue
right click on the file and select view
the fiel gets added to the transfer queue
double click the file in the transfer queue
start the queue

Too risky for me right now. Last time I downloaded it cost about three hours to
get my connections back after following the suggestion to delete the registry

Checking the properties of both the remote version and the temporary file they
are identical from the viewpoint of the current local instance of SmartFTP.
They show exactly the same date last modified (even though the file on the
remote server has been modified by another process). Consequently, thinking they
are the same, SmartFTP presents the version in the temp directory when you ask
to open/edit/view the version on the remote server.

Presumably SmartFTP thinks a file has not been modified unless it has modified it.
But this assumption is wrong causing it to present old data.

Thanks for the tip on monitoring. But I don't think turning it off will
circumvent this issue. Even if you shut down SmartFTP and restart it, it finds the
old version in the temporary directory and somehow retains the assumption the
remote file has not changed causing it to present the wrong data.

SmartFTP still shows the old version from the temporary directory rather than the current version from the server.
I think there is a bug of the 3rd kind there.

Please post the system information from the menu: Help->About "System Information". Thanks.

You are saying the date/time of the remote file is the same as the local file. If the size is the same as well the file will not be downloaded. If the file is changed on the server the file has a different date/time (unless the process changing it reset the last modified date/time at the end) and it will be downloaded.

Well the problem is more illusive than I thought. I restarted SmartFTP and it is now picking up the latest and greatest version of the file, even when it is updated by a remote process. I'll go dormant on this again until it returns. Sorry for the 180's.


You still with me on this? This problem has to do with SmartFTP caching the file
and then picking up that old cached version - even if it has since changed - the next time smartFTP starts.

Question: How can I prevent SmartFTP from caching a file in a temporary directory
when I open it from the remote server with "Edit with"? Or turn off this caching altogether?


You need to send the log from the transfer.

I'm having the same problem.
Upgraded to v4.0.1066.0
Stopped queue
Viewed file
double clicked the file in the queue, a dialog popped up with nothing in it.
Started queue.

Same old file.

Even if I then upload a new version of the file and follow same proceedure, same problem happens.

This is really bad because I've overwritten several files with older version. It doesn't happen all the time, only rarely.

edit: inspecting the file a little closer, it's appears corrupted, as if part of the file is there, and a piece of another file is appended at the bottom. Corrupted cache?
Files are uploaded only in binary mode. The file in question is a PHP file.

I've only noticed this problem over the past month or so since I upgraded.

another edit: here's the log entry
[2009-11-10T10:57:12] Log opened
[2009-11-10T10:57:12] Initializing. Transfer Queue v4.0.1066.0.
[2009-11-10T10:57:12] Operation Begin
[2009-11-10T10:57:12] SIZE
[2009-11-10T10:57:12] 213 5629
[2009-11-10T10:57:12] MDTM
[2009-11-10T10:57:12] 213 20091110182835
[2009-11-10T10:57:12] Source File: Size=5629, Time=2009-11-10T18:28:35
[2009-11-10T10:57:12] Destination File: Size=5629, Time=2009-11-10T18:28:36
[2009-11-10T10:57:12] RecentTime=2009-11-10T18:57:12
[2009-11-10T10:57:12] Rule "IF Destination Time=Newer AND Size=Equal AND Transfer=No Matter THEN Skip" matched. Action="Skip".
[2009-11-10T10:57:12] Skipping file "". Reason: User action.
[2009-11-10T10:57:12] Operation End
[2009-11-10T10:57:12] Log closed

Steve: Please open a new thread and post a detailed desscription about your problem. What are you doing exactly etc.