SmartFTP forces registration each time; wipes out Favorites

Kino500

2009-07-01 17:47:10

I think SmartFTP is a great piece of software, but it has been increasingly difficult for me to use in recent years. Trying to figure out simple settings seems to be beyond me, a 20+ year computer user and technologist.

The problem I'm having now is a real stinker. Since installing the most recent update (gawd, how I wish I could simply use an older version of this tool without the updates) I'm now forced to "re-register" the application with my XML file EACH TIME I start SmartFTP.

Add to this annoyance the fact that my SmartFTP Favorites were somehow wiped out. (What a pain!) Thankfully I had an old one backed up, but it required me to go an edit it. Then, the next time I opened the software the Favorites are ALL GONE!!

I've tried emailing sales@ and support@smartftp.com and received zero response. I'm beginning to feel like a chump for paying to register this tool.

I hope that someone in this BB will respond with some helpful advice. I'd like to love this tool again.

Thanks.

K

mb

2009-07-01 21:03:11

Hello ..

The favorites are not deleted by SmartFTP. There is actually no function implemented which deletes the favorites (.xml) files automatically. What you maybe meant is the history which is displayed in the history combo box. The history is only a list of links to the favorites though. To access the favorites directly go to the menu: Favorites.

We have responed to your emails within less than 24 hours. Try to add our domain to the whitelist.

To your problems please provide the system information from the menu: Help->About "System Information" in SmartFTP.

Regards,
Mat

Kino500

2009-07-02 16:30:44


Hello ..

The favorites are not deleted by SmartFTP. There is actually no function implemented which deletes the favorites (.xml) files automatically. What you maybe meant is the history which is displayed in the history combo box. The history is only a list of links to the favorites though. To access the favorites directly go to the menu: Favorites.

We have responed to your emails within less than 24 hours. Try to add our domain to the whitelist.

To your problems please provide the system information from the menu: Help->About "System Information" in SmartFTP.

Regards,
Mat

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2786 MHz
Total Memory : 511 MB
Free Memory : 304 MB

+- SmartFTP ---------------------------
Version : 3.0.1024.32
Time Stamp : 2008-11-23 16:59:11
Platform : x86
Id : 400069799
Days in use : 179

+- Application DLL --------------------
sfFTPLib.dll : 1.5.15.6
sfFavorites.dll : 1.0.20.32
sfFavoritesShellExtension.dll : 1.0.1.22
sfTransferQueue.dll : 1.0.17.32
sfFTPShellExtension.dll : 1.0.15.32
SmartFTPPS.dll : 3.0.1024.32

+- Language ---------------------------
SmartFTP.exe : 3.0.1024.32

+- Internet Explorer ------------------
Version : 6.0.2900.5512

+- Winsock ----------------------------
Winsock : 2.2

There's the info. Any ideas? All my Favorites were imported from a .dat file from an older version. All the folders on my menu are empty.

K

mb

2009-07-02 17:49:17

Please install the latest version from here:
https://www.smartftp.com/download

Kino500

2009-07-02 18:40:04


Please install the latest version from here:
https://www.smartftp.com/download

Issue appears to have disappeared with this version. No more nags for registration, and Favorites (the ones I retrieved) remain intact.

I would really appreciate not having to have a forced upgrade in future. My needs are simple -- move files on and off a server :-). More upgrades should be a user option, not a requirement.

Thanks

mb

2009-07-02 19:52:38

Upgrades are not forced. Maybe you forgot to activate SmartFTP with your license key and therefore you were prompted to upgrade.

Kino500

2009-07-09 22:18:10


Upgrades are not forced. Maybe you forgot to activate SmartFTP with your license key and therefore you were prompted to upgrade.

I might be going crazy, but I can't think of a time when SmartFTP didn't tell me that my version was set to expire and it was time to upgrade. This was in the early going, when for a long time I used the unlicensed version.

OK, so I've installed the latest version, and rebooted and guess what? I ran SmartFTP and it asked me to register again (You have zero days left!). So I open up my XML registration file that I keep on hand, and all my Favorites are wiped out again.

I'm running XP Pro on a Boot Camp partition on a Macbook Pro. Until this version of the software I was running the program fine for many months.

Can someone please explain? This is slowing me down a lot on an important project.

K

mb

2009-07-09 22:28:07

Hello ..

Upgrades have been forced for the unlicensed version at the time we were offering SmartFTP for free. But again this was only the case if you did not use a license and had it installed for more than 120 days.

Your registry might be corrupted. Please try this:
https://www.smartftp.com/support/kb/how- ... f2625.html

Regards,
Mat

Kino500

2009-07-10 21:05:03


Hello ..

Your registry might be corrupted. Please try this:
https://www.smartftp.com/support/kb/how ... f2625.html

Regards,
Mat

Regrettably, this has not helped. I've restarted after deleting the registry per your instructions, and when I start SFTP it once again requests the registration XML info, and my Favorites and other settings for the program once again are gone.

Any other tips?

mb

2009-07-10 22:26:54

Do you have any files in the %AppData%\SmartFTP\Client 2.0 folders?

For example the license key (SmartFTP.key) or the favorites folder?

Kino500

2009-07-10 23:27:46


Do you have any files in the %AppData%\SmartFTP\Client 2.0 folders?

For example the license key (SmartFTP.key) or the favorites folder?

Yes. All the above are in there now. Folders: Favorites, Log, Storage; Files: Custom Commands.dat, Quick Folders.dat, SmartFTP.key, Transfer Queue.xml.

Note, the program is currently open.

mb

2009-07-10 23:36:14

Close the application and see if the files still exist.

Kino500

2009-07-12 13:30:43


Close the application and see if the files still exist.

Yes they do.

mb

2009-07-12 13:55:09

Please provide the system information from the menu: Help->About "System Information" in SmartFTP.

Kino500

2009-07-13 05:54:27


Please provide the system information from the menu: Help->About "System Information" in SmartFTP.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2786 MHz
Total Memory : 511 MB
Free Memory : 135 MB

+- SmartFTP ---------------------------
Version : 3.0.1034.0
Time Stamp : 2009-06-30 21:39:02
Platform : x86
Id : 400069799
Days in use : 190

+- Application DLL --------------------
sfFTPLib.dll : 1.5.19.0
sfFavorites.dll : 1.0.30.0
sfFavoritesShellExtension.dll : 2.0.7.0
sfTransferQueue.dll : 1.0.27.0
sfFTPShellExtension.dll : 1.0.25.0
SmartFTPPS.dll : 3.0.1034.0

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 6.0.2900.5512

+- Winsock ----------------------------
Winsock : 2.2

mb

2009-07-13 14:29:59

Enable debug logging:
https://www.smartftp.com/support/kb/how- ... f2613.html

Then send the logs to support at smartftp.com

Kino500

2009-07-15 18:09:15


Enable debug logging:
https://www.smartftp.com/support/kb/how ... f2613.html

Then send the logs to support at smartftp.com

I uninstalled, deleted all the application and data folders, reinstalled and so far everything seems to be running fine. I'll respond back if the problem persists. Thanks for your help so far.

K